Bug 501149 - [PATCH] [Refactoring] A series of refactoring patches to sos (2)
[PATCH] [Refactoring] A series of refactoring patches to sos (2)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sos (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Stokes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-17 04:49 EDT by Satoru SATOH
Modified: 2009-08-07 01:06 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.8-14.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-07 01:03:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Remove the line importing re module which is already imported at the head of cluster.py (716 bytes, patch)
2009-05-17 04:49 EDT, Satoru SATOH
no flags Details | Diff
fix to catch exceptions in PluginBase.{doRegexFindAll,fileGrep} (1.91 KB, patch)
2009-05-17 17:55 EDT, Satoru SATOH
no flags Details | Diff
Remove a hack (pylint: E0203) in PluginBase.__init__ (951 bytes, patch)
2009-05-17 17:57 EDT, Satoru SATOH
no flags Details | Diff
Fix plugins.cluster.has_gfs always return bool (995 bytes, patch)
2009-05-17 18:01 EDT, Satoru SATOH
no flags Details | Diff

  None (edit)
Description Satoru SATOH 2009-05-17 04:49:44 EDT
Created attachment 344317 [details]
Remove the line importing re module which is already imported at the head of cluster.py

Description of problem:

This is not a bug report but a kind of refactoring patche set same as bz#498398.


Version-Release number of selected component (if applicable): sos-1.8-11.fc11
Comment 1 Satoru SATOH 2009-05-17 17:55:53 EDT
Created attachment 344355 [details]
fix to catch exceptions in PluginBase.{doRegexFindAll,fileGrep}

PluginBase.doRegexFindAll and PluginBase.fileGrep may throw exceptions (IOError, etc.) but some plugins do not take care that.

This patch suppress these method throw exceptions.
Comment 2 Satoru SATOH 2009-05-17 17:57:51 EDT
Created attachment 344357 [details]
Remove a hack (pylint: E0203) in PluginBase.__init__
Comment 3 Satoru SATOH 2009-05-17 18:01:24 EDT
Created attachment 344358 [details]
Fix plugins.cluster.has_gfs always return bool

There is a case that plugins.cluster.has_gfs() return nothing (I think it will be None) if no exception is thrown but regex does not match.

This patch should fix that problem.
Comment 4 Bug Zapper 2009-06-09 11:58:21 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Fedora Update System 2009-07-23 13:20:17 EDT
sos-1.8-14.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/sos-1.8-14.fc11
Comment 6 Fedora Update System 2009-07-23 13:21:51 EDT
sos-1.8-14.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/sos-1.8-14.fc10
Comment 7 Fedora Update System 2009-07-24 15:37:02 EDT
sos-1.8-14.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update sos'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7976
Comment 8 Fedora Update System 2009-07-24 15:37:52 EDT
sos-1.8-14.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update sos'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-7976
Comment 9 Fedora Update System 2009-08-07 01:03:23 EDT
sos-1.8-14.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2009-08-07 01:05:52 EDT
sos-1.8-14.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.