Bug 501155 - emits wrong upstart signals
emits wrong upstart signals
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-17 05:40 EDT by Enrico Scholz
Modified: 2014-03-16 23:18 EDT (History)
2 users (show)

See Also:
Fixed In Version: 8.95.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-19 12:38:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2009-05-17 05:40:47 EDT
Description of problem:

/etc/rc.d/rc quotes upstart events, e.g.

|  initctl emit --quiet "starting $subsys"

This is wrong because native upstart jobs are emitting these events unquoted.
Hence, handling startup of 'foo' in Fedora would require two statements:

| start on starting\ foo
| start on starting foo

Former deals with Fedora initscripts, latter with native upstart jobs.

It would be nice when the correct event gets emitted.


Version-Release number of selected component (if applicable):

initscripts-8.95-1.x86_64
Comment 2 Fedora Update System 2009-12-05 10:22:50 EST
initscripts-8.95.1-1 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/initscripts-8.95.1-1
Comment 3 Fedora Update System 2009-12-21 23:49:55 EST
initscripts-8.95.1-1 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.