Bug 501181 - Glest tutorials are missing
Glest tutorials are missing
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glest (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Bruno Wolff III
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-17 11:47 EDT by Julien Thébaud
Modified: 2009-11-07 15:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-07 15:08:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julien Thébaud 2009-05-17 11:47:40 EDT
Description of problem:
Glest tutorials are missing

Version-Release number of selected component (if applicable):
glest-3.2.1-1.fc11

How reproducible:
always

Steps to Reproduce:
1. Launch glest
2. Choose New game > Tutorial
  
Actual results:
Nothing happens

Expected results:
Tutorials could be played

Additional info:
The symbolic link is missing between /usr/share/glest/tutorials and $HOME/.glest/tutorials
Comment 1 Tristan Moody 2009-05-20 17:53:59 EDT
Fix: 

In glest.sh, line 67:

Change "for dir in techs data maps scenarios tilesets; do"
to "for dir in techs data maps scenarios tilesets tutorials; do"

That should fix the problem.
Comment 2 Bug Zapper 2009-06-09 11:58:53 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Bruno Wolff III 2009-08-22 23:31:02 EDT
It looks like that change got made in the package by the previous packager just before I volunteered to take over. There is now a new build in rawhide that isn't tested yet (3d video makes it difficult for me). I'd be interested in hearing if that works for you.
Comment 4 Julien Thébaud 2009-08-23 04:32:26 EDT
I update to the rawhide version, but the bug is still here...
Comment 5 Bruno Wolff III 2009-08-23 10:09:15 EDT
Thank you for the feedback.
I'll be double checking this when I get it on a live spin so I can test it on a machine that has a 3d capable card. That might not be for another day or to.
I also want to make sure you tried glest-3.2.2-1.fc12. The build for rawhide was just done last night and unless you pulled it from koji, it might not have been at the mirror you used at the time you filed the comment. (It's at one of the kernel.org mirrors now, but a lot of mirrors don't update that often.)
Comment 6 Bruno Wolff III 2009-08-25 16:46:45 EDT
I suspect that you got the old one. But when I got a live DVD version to test on a machine that has 3d support, glest crashed with a segfault. So I need to do some more work to try to track this down. If your experience is different I would be interested in hearing it.
Comment 7 Julien Thébaud 2009-08-26 13:21:38 EDT
Actually, I didn't have the latest version and the bug is now gone. I think this ticket can be closed.

I had a segfault with a previous release on F10 but not yet since one of the update. But there is still that: https://bugzilla.redhat.com/show_bug.cgi?id=501232
Comment 8 Bruno Wolff III 2009-11-07 15:08:40 EST
Tutorials are working in the F12 version. I don't want to risk backporting stuff to F11 or F10 at this time.

Note You need to log in before you can comment on or make changes to this bug.