Bug 501182 - Very slow trapezoid rasterization
Very slow trapezoid rasterization
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-17 12:01 EDT by Clemens Eisserer
Modified: 2009-06-12 19:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-12 19:36:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sysprof profile of OOo moving simple chart arround (1.01 MB, text/plain)
2009-05-17 12:04 EDT, Clemens Eisserer
no flags Details
FireFox performance comparison of XAA, EXA and UXA (15.02 KB, application/octet-stream)
2009-05-18 15:32 EDT, Clemens Eisserer
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 21376 None None None Never

  None (edit)
Description Clemens Eisserer 2009-05-17 12:01:49 EDT
Description of problem:

All applications which render a lot of trapezoids are quite slow when using UXA+KMS. I guess this is caused by the fix for bug 490839.


Version-Release number of selected component (if applicable):
kernel  2.6.29.3-140.fc11.i586
intel 2.7.0-4
xorg 1.6.1

How reproducible:
Always. Some applications suffer less, some a lot (OpenOffice 3.1, FireFox for some pages).

Steps to Reproduce:
1. Open an openoffice(3.1)-document 
1.2. Move e.g. a chart arround
2. Open a trapezoid-heavy page in firefox.
  
Actual results:
Very slow rendering of trapezoids, profilers show almost all time spent in pixman_rasterize_edges.
Because the amount of trapezoids is the same for EXA/XAA/UXA the only conclusion I can make is that memory access is uncached and therefor slowing that code down.

Expected results:
At least as fast as EXA

Additional info:
Intel-945GM

I reported this bug already upstream, however I am not sure its really their fault:
https://bugs.freedesktop.org/show_bug.cgi?id=21376
Comment 1 Clemens Eisserer 2009-05-17 12:04:14 EDT
Created attachment 344335 [details]
sysprof profile of OOo moving simple chart arround
Comment 2 Clemens Eisserer 2009-05-18 15:31:35 EDT
I did some firefox performance measurements using Trender.
XAA/EXA was on Fedora8 with intel-2.2.1
UXA was on Fedora 10 with KMS

The steady slowdown is concerning  :-/
Comment 3 Clemens Eisserer 2009-05-18 15:32:51 EDT
Created attachment 344509 [details]
FireFox performance comparison of XAA, EXA and UXA
Comment 4 Bug Zapper 2009-06-09 11:59:04 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Clemens Eisserer 2009-06-12 19:36:53 EDT
This is an intel-bug, caused by rendering trapezoid to pixmaps instead of system memory. Should be fixed in 2.8 (pre releases).

Note You need to log in before you can comment on or make changes to this bug.