This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 501211 - ibus-setup window should be raised if running or just stay on top/grab focus
ibus-setup window should be raised if running or just stay on top/grab focus
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-17 22:41 EDT by Jens Petersen
Modified: 2009-05-28 04:04 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.1.0.20090508-5.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-28 04:04:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2009-05-17 22:41:17 EDT
Description of problem:
Currently ibus-setup (and other IME setups) can be lowered and lose focus.
If user then tries to select ibus-setup again from applet then "nothing"
happens since it is already running.

Steps to Reproduce:
1. run ibus-setup
2. bring another window in front
3. try to start ibus-setup from ibus -> Preferences
  
Actual results:
nothing happens

Expected results:
ibus-expect would get focus

Additional info:
Probably simple workaround is just to have ibus-setup to grab desktop, so users have to close it, before continuing.  If that is not too aggressive?
Comment 1 Peng Huang 2009-05-25 04:19:48 EDT
I think grab desktop is too aggressive.
I'd like raise the window. but it has some limitation, ibus->Preferences can not raise the ibus setup dialog executed by user self, it will bring another one.
It has been implemented in upstream. I will build it for fedora soon.
Comment 2 Fedora Update System 2009-05-25 05:04:51 EDT
ibus-1.1.0.20090508-4.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/ibus-1.1.0.20090508-4.fc11
Comment 3 Fedora Update System 2009-05-26 03:54:38 EDT
ibus-1.1.0.20090508-4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ibus'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-5495
Comment 4 Fedora Update System 2009-05-26 22:02:11 EDT
ibus-1.1.0.20090508-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/ibus-1.1.0.20090508-5.fc11
Comment 5 Fedora Update System 2009-05-28 04:04:33 EDT
ibus-1.1.0.20090508-5.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.