This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 501214 - need better logo and panel icons: light blue ibus icon is not obvious
need better logo and panel icons: light blue ibus icon is not obvious
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-17 23:55 EDT by Jens Petersen
Modified: 2010-08-02 21:00 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-02 21:00:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
current ibus panel icon (15.80 KB, image/svg+xml)
2009-05-18 11:39 EDT, Máirín Duffy
no flags Details
The screenshot of the system tray bar. (75.49 KB, image/png)
2009-08-24 02:05 EDT, Peng Huang
no flags Details
icon on tray bar (13.91 KB, image/png)
2009-08-25 03:02 EDT, Peng Huang
no flags Details

  None (edit)
Description Jens Petersen 2009-05-17 23:55:18 EDT
Description of problem:
The ibus icon in the panel is not obvious and hard for first-time users to understand.

Steps to Reproduce:
1. start fedora desktop with ibus
2. try to find out how to control IM
  
Actual results:
2. The current icon has no obvious connection with keyboard or input other than 'i'.

Expected results:
Clearer icon which new users can quickly recognise as for inputs.

Additional info:
Actually I would like to change the panel UI so that it more obvious what the current input method is when ibus is off.

eg It could show a cross over the IME icon to show that IM is off,
a bit like gnome-power-manager's inhibit applet for example.
Or maybe we don't need custom icons for IMEs and just use
a character for each IME to represent it and display that in the applet.
Comment 1 Máirín Duffy 2009-05-18 11:39:23 EDT
Created attachment 344459 [details]
current ibus panel icon
Comment 2 Máirín Duffy 2009-05-18 11:40:31 EDT
icon should be 24x24 for panel...
Comment 3 Mike Langlie 2009-05-19 13:46:07 EDT
I made a new icon combining a blank keyboard key and globe to indicate potential choice of input method language. The color should match the existing iBus set. 

PNGs can be found here:
http://productdesign.usersys.redhat.com/wiki/IBus

If people like the icon I will make SVGs.
Comment 4 Mike Langlie 2009-05-20 13:30:15 EDT
Working on alternate ideas. Including angled, multiple keys with international characters.
Comment 5 Peng Huang 2009-05-24 23:32:07 EDT
(In reply to comment #3)
> I made a new icon combining a blank keyboard key and globe to indicate
> potential choice of input method language. The color should match the existing
> iBus set. 
> 
> PNGs can be found here:
> http://productdesign.usersys.redhat.com/wiki/IBus
> 
> If people like the icon I will make SVGs. 

Thanks. It looks good. And wait for your next ideas.
Comment 6 Jens Petersen 2009-05-25 19:57:15 EDT
(In reply to comment #3)
> http://productdesign.usersys.redhat.com/wiki/IBus

Take 1 looks ok to me (I am less interested in the specific chars in take 2 and 3).  Not sure if we really need the world in the background.
Comment 7 Peng Huang 2009-05-25 20:18:37 EDT
I think 22x22 and 24x24 are more important. IBus uses them on SysTray area and language panel. We should make sure they are clear for users. I think characters in 22x22 and 24x24 icons are little small.
Comment 8 Jens Petersen 2009-05-25 22:44:42 EDT
If it is svg can't the panel applet scale the icon, anyway?
Comment 9 Peng Huang 2009-05-26 01:04:34 EDT
svg can be scaled. But some icons does not look good in 22x22 or 24x24. Because the icon is too small, some details of icons will be lost.
Comment 10 Mike Langlie 2009-05-26 13:24:49 EDT
I added a new (4th) icon. It's a full keyboard with a globe as an emblem.
Comment 11 Bug Zapper 2009-06-09 12:01:17 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Jens Petersen 2009-06-21 22:26:00 EDT
So how about adopting one of these icons or do we need changes?
Comment 13 Jens Petersen 2009-07-28 04:33:20 EDT
Mike, that was very timely.

Now I like the newest icon best. :)

Phuang, how about with go with take4 for F12?
If you are ok then can you add it upstream?
Comment 14 Jens Petersen 2009-07-28 05:12:48 EDT
If so let's ask Mike to prepare a svg.
Comment 15 Jens Petersen 2009-08-19 03:30:08 EDT
Hi Mike can you make a svg of take-4 for us?
Comment 16 Máirín Duffy 2009-08-19 15:37:43 EDT
Hi Jens. Mike is no longer with Red Hat. Is the SVG required? Usually we ship PNGs so they are pixel-perfect for the required sizes. If you really need an SVG version I can do it - I'm guessing the SVG shold be optimized for 48x48 the same as the scalable icon versions in the gnome icon theme are?
Comment 17 Peng Huang 2009-08-20 01:51:01 EDT
If it is convenient, please provide both SVG and PNG format for each sizes. And we could try them in application. Thanks.

BTW, I think take-4 could remove the earth and make the keyboard bigger, and than it will become more obvious to indicate the current input states.

Another thing. Could you help to create a beautiful project logo for ibus?
Comment 18 Máirín Duffy 2009-08-21 10:18:29 EDT
Hi Huang!

Mike already provided the icon in various sizes:

http://productdesign.usersys.redhat.com/w/images/8/81/IBus4-16.png
http://productdesign.usersys.redhat.com/w/images/c/cd/IBus4-22.png
http://productdesign.usersys.redhat.com/w/images/c/c5/IBus4-24.png
http://productdesign.usersys.redhat.com/w/images/7/7c/IBus4-32.png

It seems he left out 48x48 so I've created this for you, plus an SVG version of 48x48:

http://productdesign.usersys.redhat.com/w/images/c/ca/IBus4-48.png
http://productdesign.usersys.redhat.com/w/images/0/02/IBus4-48.svg

I don't agree that we could remove the earth from the icon and I'll tell you why - this icon builds on the standard keyboard icon in the gnome-icon-theme. The globe distinguishes it from the general keyboard settings icon by having the globe, which in comparison is needed to make it clear it's specifically for i18n-related keyboard set up. Does it make more sense to you to have the globe now?

I would be delighted to help you with creating a project logo for ibus. What do you intend to use it for - it's not going to be used as an icon or anything right? Are you going to create a webpage about ibus or use it for the documentation or upstream project? Let me know, that will help me figure out how to format the logo.
Comment 19 Peng Huang 2009-08-24 02:05:04 EDT
Created attachment 358401 [details]
The screenshot of the system tray bar.

Just tried the new icon. Its contrast is too low, especially on panel with white or gray background color (Please look the attached picture). I think we need a colorful icon, and it should have high contrast, and it is better that graphics (the earth and the keyboard) have clear outline.
Comment 20 Máirín Duffy 2009-08-24 10:11:40 EDT
Hi Huang, which version of the icon are you using there? It looks like it's the wrong size and it's getting aliased.
Comment 21 Peng Huang 2009-08-24 23:12:07 EDT
I used the IBus4-48.svg. Should I try the IBus4-22.png or 16?
Comment 22 Peng Huang 2009-08-25 03:02:28 EDT
Created attachment 358528 [details]
icon on tray bar

I tried 22x22, it is better.
Comment 23 Peng Huang 2009-08-25 03:38:56 EDT
Do you have all size icons in svg format? Please share them. Thanks.
Comment 24 Máirín Duffy 2009-08-25 12:31:28 EDT
Hi Huang, 

Like I mentioned in comment #16, we typically only use icons in PNG format, and keep a scalable version of the 48x48 icon available - this is the way the default icon set gnome-icon-theme works.

It would be a lot of extra work for me to produce SVGs for all the sizes. Is there some reason you can't use PNGs? 

Thanks.
Comment 25 Peng Huang 2009-08-25 20:55:57 EDT
This icon is used on system tray bar. Generally, the height of the panel is 24, so the 22x22 png is OK. But if user set panel's height to 48 or bigger, this icon can not be displayed clearly. And this icon is not a theme icon in gnome-icon-theme, currently it is installed by ibus. I don't know how to install several different size icons. So I want have an icon in svg format, and it could be displayed in small & big size clearly.

BTW, if gnome-icon-theme could add some icons for input method, it will be perfect. Is it possible to add some input methods icons into gnome-icon-theme? If the theme provides those icons,  I think ibus could choice icons from theme by default, and if im icons do not exist, ibus will pick up icon installed by self.
Comment 26 Jens Petersen 2009-08-25 23:19:39 EDT
(In reply to comment #25)
> So I want have an icon in svg format, and
> it could be displayed in small & big size clearly.

Right, so isn't one 48px svg icon sufficient?
Comment 27 Máirín Duffy 2009-08-25 23:43:51 EDT
Hi Huang,

Have you tried resizing your panel from 24 px tall to 48 px tall? For me, in F11 in GNOME, if I size my panel up from 24 px tall to 48 px tall, GNOME automatically looks up and grabs the 48px size PNG file, if available. Try it now and you'll see what I mean. As long as you install the icons to the correct directories using the correct format, resizing PNG icons in the panel is not a concern.

You should not use the SVG of the icon, it will not be pixel-perfect, the rendering library GNOME uses to render SVGs is slow and buggy, and it isn't standard practice to use SVG icons. You should instead use the provided PNG icons. 

If you need help, please refer to the "Directory Layout" section of the GNOME Icon Theme spec: http://library.gnome.org/devel/icon-theme-spec/  

I do believe what this will involve is installing the appropriate icon to each of the following directories: 

- /usr/share/icons/hicolor/16x16 
- /usr/share/icons/hicolor/22x22 
- /usr/share/icons/hicolor/24x24 
- /usr/share/icons/hicolor/32x32 
- /usr/share/icons/hicolor/48x48

I don't know if the gnome-icon-theme provides input-method icons but from my perusal of the directory it appears not. I do not see any icons for this mentioned in the freedesktop icon spec either: http://standards.freedesktop.org/icon-naming-spec/icon-naming-spec-latest.html
Comment 28 Peng Huang 2009-08-26 04:10:16 EDT
Thanks for providing those detail information. I will try it.
Comment 29 Jens Petersen 2009-08-26 04:52:33 EDT
(In reply to comment #17)
> Could you help to create a beautiful project logo for ibus?  

Mairin, I think phuang was hoping that a nice project logo
could also be created for ibus at the same time
since ibus is largely driven by fedora.
Is that something you could help with? :)
Comment 30 Máirín Duffy 2009-08-26 09:34:02 EDT
Hi Jens, I'd be happy to help with a logo :) For me to understand how to best format it though, I need to know how you folks intend to use it - is this for a project web page? An About dialog? A banner? Is it going to be the upstream logo for the project?
Comment 31 Peng Huang 2009-08-26 22:46:04 EDT
Mairin, This icon will be used in desktop file, and in about dialog. And we also need a picture in project web page (http://code.google.com/p/ibus), the size is a maximum of 153 x 55 pixels (it may be same with the icon).

Some information about ibus, maybe is useful for making the pictures.
It is an input methods framework, it manages all input method engines in system.
It is bus center architecture, all engines and clients establish connection to ibus, and them transfer messages between each others via the ibus.

I don't know if you use any input methods. The input methods are for non-English users, especially for CJKI, it receives input from user typing, and converts several ASCII chars to one or more CJKI chars by some logic.

FYI, Below are some refs to other input method frameworks.
http://www.fcitx.org/main/
http://www.scim-im.org/
Comment 32 Máirín Duffy 2009-08-27 00:48:30 EDT
Hi Huang,

Okay, cool. So the logo could be horizontally wide, but if you're going to do a logo icon too it should probably be just part of the logo iconified. 

I've used ibus once before but only briefly tried it; I'm used to doing Japanese input in SCIM. I'll try to find some screenshots of ibus so i can get a feel for how it looks.

Do you have a hard deadline for when this new work should be completed?
Comment 33 Peng Huang 2009-08-27 05:01:21 EDT
It does not have a hard deadline, but earlier is better. :)
Comment 34 Peng Huang 2009-08-28 02:32:34 EDT
The new icons has been included in this build
http://koji.fedoraproject.org/koji/buildinfo?buildID=129611
Comment 36 Bug Zapper 2009-11-16 04:59:18 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 37 Jens Petersen 2010-06-30 01:27:48 EDT
It is probably better to work on the project icon separately upstream.

So I think this bug can probably be closed now.
Comment 38 fujiwara 2010-07-08 22:08:04 EDT
If none has any problems, I'll close this bug next week.
Comment 39 Fedora Admin XMLRPC Client 2010-08-02 02:09:24 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Note You need to log in before you can comment on or make changes to this bug.