Bug 501222 - Evolution has stopped connecting to the IMAP server
Evolution has stopped connecting to the IMAP server
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
10
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-18 01:02 EDT by manjunaths
Modified: 2009-12-18 04:27 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 04:27:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Evolution password prompt window with AUTHENTICATE error (26.22 KB, image/jpeg)
2009-05-18 01:02 EDT, manjunaths
no flags Details
Debug log (85.50 KB, text/plain)
2009-05-18 01:05 EDT, manjunaths
no flags Details

  None (edit)
Description manjunaths 2009-05-18 01:02:15 EDT
Created attachment 344380 [details]
Evolution password prompt window with AUTHENTICATE error

Evolution was perfectly working until an update was pushed on fedora 10. The version of evolution currently installed is 'GNOME evolution 2.24.5.' Whenever I try to connect to the exchange server I get asked the password, when I enter the password it comes back asking for the password again with an AUTHENTICATE failed message. The image of the password prompt window with the error message is attached. 
I did a clean install and tried again. It succeeds in connecting and downloading the headers and messages the first time, and is usable. But if I close the session and start it again it fails with the same error (AUTHENTICATE failed).
Note that thunderbird works perfectly with the same imap server and in fact evolution works once on a fresh install. And from the same box used to work very previously.

The debug log is also attached.

Regards,
Manju
Comment 1 manjunaths 2009-05-18 01:05:29 EDT
Created attachment 344382 [details]
Debug log

Debug log with CAMEL_DEBUG=all set.
Comment 2 Milan Crha 2009-05-19 07:20:26 EDT
Oh, you are using an NTLM authentication against EEX 2007 server through IMAP. There had been done some changes in bug #487685, see bug #487685 comment #25:

> evolution-data-server-2.24.5-4.fc10 has been pushed to the Fedora 10 stable
> repository.  If problems still persist, please make note of it in this bug
> report.

Could you try to downgrade to the version just before that one, whether it'll help, please?
Comment 3 manjunaths 2009-05-25 01:06:41 EDT
I downgraded evolution to 2.24.1-2 and now I get the error. 

'IMAP Command Failed: Command received in Invalid state.'

and it keeps putting up the password prompt repeatedly. Sometimes
I get this error also...

'IMAP command failed:  Command Error. 12'

Do you have a particular version that I need to downgrade to ?

Thanks,
Manju
Comment 4 manjunaths 2009-05-25 01:24:40 EDT
I downgraded to version 2.24.2-1 and set the authentication to 'password' instead of NTLM/SPA and now I can login and use evolution.

Thanks,
Manju
Comment 5 Milan Crha 2009-05-25 06:41:00 EDT
I thought about downgrading evolution-data-server package to
evolution-data-server-2.24.5-3.fc10
or any nearest lower version, not necessary to downgrade evolution itself, if not forced by rpm/yum.
Comment 6 Milan Crha 2009-05-25 18:03:40 EDT
Weird, I just tried the similar situation with these packages:
  evolution-data-server-2.24.5-5.fc10.x86_64
  evolution-2.24.5-1.fc10.x86_64
  glib2-2.18.4-1.fc10.x86_64
  gtk2-2.14.7-1.fc10.x86_64

and the NTLM/SPA and it doesn't claim as for you, it works fine here.
Comment 7 manjunaths 2009-06-01 00:57:57 EDT
Ok, this is weird. I updated to the version you specified above. I shutdown evolution completely (using --force-shutdown) and started evolution. It logged in and was able to fetch me my e-mail. The authentication method was password. I changed the authentication to NTLM/SPA and tried and it was able to fetch the e-mail. I closed evolution and then did a --force-shutdown and restarted evolution again. It failed to get e-mail same error as above (authentication was NTLM/SPA) I switched to password authentication and tried getting e-mail, and I got the same AUTHENTICATE failed message. I shutdown evolution (completely) and restarted it. The authentication is password and it works now!
So here is the deal.

Upgrade evolution, restart everything, works with password authentication.
Change authentication to NTLM/SPA, check mail works.
Restart evolution and authentication fails. Change to password authentication and it fails again.
Restart evolution and it works (because the authentication is set to password??)

I am at my wits' end, but atleast it is now working.

Manju
Comment 8 Milan Crha 2009-06-01 05:48:32 EDT
Might be that the change of authentication method is not propagated properly to the UI until restart of evolution. This is out of NTLM authentication issue you are facing.

I've no idea what is different on your machine that I can connect to exchange 2007 with NTLM authentication here, but you cannot, especially when we both use the same packages.
Comment 9 Sergey Panov 2009-06-13 02:11:52 EDT
My problems began when evolution-data-server-2.24.5-4 was pushed out via F10 update repositories. I left comment in closed bug #487685 :

"I am using 4 different Fedora 10 machines. When this bug fix was pushed through
Fedora 10 update (evolution-data-server-2.24.5-4.fc10) it killed (one-by-one)
password authentication with the SMTP server. The SMTP server is a Windows 2003
server running Exchange. Password type is set to  NTLM/SPA ."

All machines updated to evolution-data-server-2.24.5-5 and problem is still there. Moreover, evolution on one of the machines does not authenticate with the exchange via evolution exchange plugin .
Comment 10 Roger 2009-07-27 22:48:47 EDT
I have the same problem using the IMAP plugin against Exchange 2007 with Evolution and NTLM/SPA authentication. After returning to Password type authentication I could successfully authenticate.


evolution-exchange-2.26.3-1.fc11.x86_64
evolution-data-server-devel-2.26.3-1.fc11.x86_64
evolution-help-2.26.3-1.fc11.noarch
evolution-data-server-doc-2.26.3-1.fc11.noarch
evolution-2.26.3-1.fc11.x86_64
evolution-perl-2.26.3-1.fc11.x86_64
evolution-data-server-2.26.3-1.fc11.x86_64

FWIW:

[roger@proust ~]$ ldd /usr/lib64/libedataserver-1.2.so.11
	linux-vdso.so.1 =>  (0x00007fff235e6000)
	libxml2.so.2 => /usr/lib64/libxml2.so.2 (0x00007fd95fee5000)
	libbonobo-2.so.0 => /usr/lib64/libbonobo-2.so.0 (0x00007fd95fc70000)
	libbonobo-activation.so.4 => /usr/lib64/libbonobo-activation.so.4 (0x00007fd95fa54000)
	libORBit-2.so.0 => /usr/lib64/libORBit-2.so.0 (0x00007fd95f7e5000)
	libgthread-2.0.so.0 => /lib64/libgthread-2.0.so.0 (0x00007fd95f5e1000)
	librt.so.1 => /lib64/librt.so.1 (0x00007fd95f3d8000)
	libgconf-2.so.4 => /usr/lib64/libgconf-2.so.4 (0x00007fd95f19a000)
	libplds4.so => /lib64/libplds4.so (0x00007fd95ef97000)
	libplc4.so => /lib64/libplc4.so (0x00007fd95ed92000)
	libnspr4.so => /lib64/libnspr4.so (0x00007fd95eb57000)
	libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fd95e93b000)
	libsoup-2.4.so.1 => /usr/lib64/libsoup-2.4.so.1 (0x00007fd95e6ed000)
	libgio-2.0.so.0 => /lib64/libgio-2.0.so.0 (0x00007fd95e475000)
	libgobject-2.0.so.0 => /lib64/libgobject-2.0.so.0 (0x00007fd95e232000)
	libgmodule-2.0.so.0 => /lib64/libgmodule-2.0.so.0 (0x00007fd95e02e000)
	libglib-2.0.so.0 => /lib64/libglib-2.0.so.0 (0x00007fd95dd50000)
	libsasl2.so.2 => /usr/lib64/libsasl2.so.2 (0x00007fd95db36000)
	libssl.so.8 => /usr/lib64/libssl.so.8 (0x00007fd95d8e4000)
	libcrypto.so.8 => /usr/lib64/libcrypto.so.8 (0x00007fd95d560000)
	libdl.so.2 => /lib64/libdl.so.2 (0x00007fd95d35c000)
	libz.so.1 => /lib64/libz.so.1 (0x00007fd95d146000)
	libc.so.6 => /lib64/libc.so.6 (0x00007fd95cdd8000)
	libm.so.6 => /lib64/libm.so.6 (0x00007fd95cb54000)
	libORBitCosNaming-2.so.0 => /usr/lib64/libORBitCosNaming-2.so.0 (0x00007fd95c94d000)
	/lib64/ld-linux-x86-64.so.2 (0x00007fd96047d000)
	libdbus-1.so.3 => /lib64/libdbus-1.so.3 (0x00007fd95c70f000)
	libgnutls.so.26 => /usr/lib64/libgnutls.so.26 (0x00007fd95c464000)
	libgcrypt.so.11 => /lib64/libgcrypt.so.11 (0x00007fd95c1f1000)
	libselinux.so.1 => /lib64/libselinux.so.1 (0x00007fd95bfd3000)
	libresolv.so.2 => /lib64/libresolv.so.2 (0x00007fd95bdb9000)
	libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00007fd95bb82000)
	libgssapi_krb5.so.2 => /usr/lib64/libgssapi_krb5.so.2 (0x00007fd95b956000)
	libkrb5.so.3 => /usr/lib64/libkrb5.so.3 (0x00007fd95b6b6000)
	libcom_err.so.2 => /lib64/libcom_err.so.2 (0x00007fd95b4b3000)
	libk5crypto.so.3 => /usr/lib64/libk5crypto.so.3 (0x00007fd95b28d000)
	libcap.so.2 => /lib64/libcap.so.2 (0x00007fd95b088000)
	libtasn1.so.3 => /usr/lib64/libtasn1.so.3 (0x00007fd95ae77000)
	libgpg-error.so.0 => /lib64/libgpg-error.so.0 (0x00007fd95ac74000)
	libfreebl3.so => /lib64/libfreebl3.so (0x00007fd95aa15000)
	libkrb5support.so.0 => /usr/lib64/libkrb5support.so.0 (0x00007fd95a80c000)
	libkeyutils.so.1 => /lib64/libkeyutils.so.1 (0x00007fd95a60a000)
	libattr.so.1 => /lib64/libattr.so.1 (0x00007fd95a405000)


[roger@proust ~]$ ldd /usr/bin/evolution 
	linux-vdso.so.1 =>  (0x00007fff9efff000)
	libeshell.so.0 => /usr/lib64/evolution/2.26/libeshell.so.0 (0x00007f6f4b51e000)
	libetimezonedialog.so.0 => /usr/lib64/evolution/2.26/libetimezonedialog.so.0 (0x00007f6f4b318000)
	libemiscwidgets.so.0 => /usr/lib64/evolution/2.26/libemiscwidgets.so.0 (0x00007f6f4b0a3000)
	libebackend-1.2.so.0 => /usr/lib64/libebackend-1.2.so.0 (0x00007f6f4ae9d000)
	libhal.so.1 => /usr/lib64/libhal.so.1 (0x00007f6f4ac8d000)
	libnotify.so.1 => /usr/lib64/libnotify.so.1 (0x00007f6f4aa85000)
	libgdata-1.2.so.1 => /usr/lib64/libgdata-1.2.so.1 (0x00007f6f4a87a000)
	libgdata-google-1.2.so.1 => /usr/lib64/libgdata-google-1.2.so.1 (0x00007f6f4a676000)
	libetext.so.0 => /usr/lib64/evolution/2.26/libetext.so.0 (0x00007f6f4a463000)
	libetable.so.0 => /usr/lib64/evolution/2.26/libetable.so.0 (0x00007f6f4a1e0000)
	libevolution-widgets-a11y.so.0 => /usr/lib64/evolution/2.26/libevolution-widgets-a11y.so.0 (0x00007f6f49fd7000)
	libevolution-a11y.so.0 => /usr/lib64/evolution/2.26/libevolution-a11y.so.0 (0x00007f6f49dc0000)
	libeutil.so.0 => /usr/lib64/evolution/2.26/libeutil.so.0 (0x00007f6f49b7d000)
	libcamel-provider-1.2.so.14 => /usr/lib64/libcamel-provider-1.2.so.14 (0x00007f6f49910000)
	libgtkhtml-editor.so.0 => /usr/lib64/libgtkhtml-editor.so.0 (0x00007f6f496d8000)
	libssl3.so => /lib64/libssl3.so (0x00007f6f494a8000)
	libsmime3.so => /lib64/libsmime3.so (0x00007f6f4927e000)
	libnss3.so => /lib64/libnss3.so (0x00007f6f48f4d000)
	libnssutil3.so => /lib64/libnssutil3.so (0x00007f6f48d2f000)
	libedataserverui-1.2.so.8 => /usr/lib64/libedataserverui-1.2.so.8 (0x00007f6f48af9000)
	libebook-1.2.so.9 => /usr/lib64/libebook-1.2.so.9 (0x00007f6f488bd000)
	libcamel-1.2.so.14 => /usr/lib64/libcamel-1.2.so.14 (0x00007f6f48640000)
	libsqlite3.so.0 => /usr/lib64/libsqlite3.so.0 (0x00007f6f483b7000)
	libplds4.so => /lib64/libplds4.so (0x00007f6f481b4000)
	libplc4.so => /lib64/libplc4.so (0x00007f6f47fb0000)
	libnspr4.so => /lib64/libnspr4.so (0x00007f6f47d75000)
	libdl.so.2 => /lib64/libdl.so.2 (0x00007f6f47b71000)
	libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f6f47955000)
	libX11.so.6 => /usr/lib64/libX11.so.6 (0x00007f6f4761c000)
	libgpilotd.so.2 => /usr/lib64/libgpilotd.so.2 (0x00007f6f47403000)
	libgpilotdcm.so.2 => /usr/lib64/libgpilotdcm.so.2 (0x00007f6f471fc000)
	libgpilotdconduit.so.2 => /usr/lib64/libgpilotdconduit.so.2 (0x00007f6f46fe6000)
	libpisock.so.9 => /usr/lib64/libpisock.so.9 (0x00007f6f46da6000)
	libpisync.so.1 => /usr/lib64/libpisync.so.1 (0x00007f6f46ba2000)
	libecal-1.2.so.7 => /usr/lib64/libecal-1.2.so.7 (0x00007f6f46957000)
	libical.so.0 => /usr/lib64/libical.so.0 (0x00007f6f466fa000)
	libicalss.so.0 => /usr/lib64/libicalss.so.0 (0x00007f6f464e4000)
	libicalvcal.so.0 => /usr/lib64/libicalvcal.so.0 (0x00007f6f462d1000)
	libedataserver-1.2.so.11 => /usr/lib64/libedataserver-1.2.so.11 (0x00007f6f460a6000)
	libsoup-2.4.so.1 => /usr/lib64/libsoup-2.4.so.1 (0x00007f6f45e59000)
	libgtkhtml-3.14.so.19 => /usr/lib64/libgtkhtml-3.14.so.19 (0x00007f6f45b8a000)
	libgnomeui-2.so.0 => /usr/lib64/libgnomeui-2.so.0 (0x00007f6f458f0000)
	libSM.so.6 => /usr/lib64/libSM.so.6 (0x00007f6f456e8000)
	libICE.so.6 => /usr/lib64/libICE.so.6 (0x00007f6f454cc000)
	libglade-2.0.so.0 => /usr/lib64/libglade-2.0.so.0 (0x00007f6f452b3000)
	libenchant.so.1 => /usr/lib64/libenchant.so.1 (0x00007f6f450a9000)
	libbonoboui-2.so.0 => /usr/lib64/libbonoboui-2.so.0 (0x00007f6f44e3b000)
	libgnomevfs-2.so.0 => /usr/lib64/libgnomevfs-2.so.0 (0x00007f6f44bd3000)
	libgnomecanvas-2.so.0 => /usr/lib64/libgnomecanvas-2.so.0 (0x00007f6f4499e000)
	libgnome-2.so.0 => /usr/lib64/libgnome-2.so.0 (0x00007f6f44788000)
	libpopt.so.0 => /lib64/libpopt.so.0 (0x00007f6f4457f000)
	libbonobo-2.so.0 => /usr/lib64/libbonobo-2.so.0 (0x00007f6f4430a000)
	libbonobo-activation.so.4 => /usr/lib64/libbonobo-activation.so.4 (0x00007f6f440ef000)
	libORBit-2.so.0 => /usr/lib64/libORBit-2.so.0 (0x00007f6f43e80000)
	libart_lgpl_2.so.2 => /usr/lib64/libart_lgpl_2.so.2 (0x00007f6f43c67000)
	libgconf-2.so.4 => /usr/lib64/libgconf-2.so.4 (0x00007f6f43a29000)
	libgthread-2.0.so.0 => /lib64/libgthread-2.0.so.0 (0x00007f6f43825000)
	librt.so.1 => /lib64/librt.so.1 (0x00007f6f4361d000)
	libgtk-x11-2.0.so.0 => /usr/lib64/libgtk-x11-2.0.so.0 (0x00007f6f4303c000)
	libxml2.so.2 => /usr/lib64/libxml2.so.2 (0x00007f6f42cec000)
	libgdk-x11-2.0.so.0 => /usr/lib64/libgdk-x11-2.0.so.0 (0x00007f6f42a4e000)
	libatk-1.0.so.0 => /usr/lib64/libatk-1.0.so.0 (0x00007f6f4282f000)
	libgio-2.0.so.0 => /lib64/libgio-2.0.so.0 (0x00007f6f425b7000)
	libpangoft2-1.0.so.0 => /usr/lib64/libpangoft2-1.0.so.0 (0x00007f6f4238a000)
	libgdk_pixbuf-2.0.so.0 => /usr/lib64/libgdk_pixbuf-2.0.so.0 (0x00007f6f4216d000)
	libpangocairo-1.0.so.0 => /usr/lib64/libpangocairo-1.0.so.0 (0x00007f6f41f62000)
	libcairo.so.2 => /usr/lib64/libcairo.so.2 (0x00007f6f41cec000)
	libpango-1.0.so.0 => /usr/lib64/libpango-1.0.so.0 (0x00007f6f41aa3000)
	libfreetype.so.6 => /usr/lib64/libfreetype.so.6 (0x00007f6f4180a000)
	libfontconfig.so.1 => /usr/lib64/libfontconfig.so.1 (0x00007f6f415d5000)
	libgmodule-2.0.so.0 => /lib64/libgmodule-2.0.so.0 (0x00007f6f413d2000)
	libdbus-glib-1.so.2 => /usr/lib64/libdbus-glib-1.so.2 (0x00007f6f411b1000)
	libdbus-1.so.3 => /lib64/libdbus-1.so.3 (0x00007f6f40f73000)
	libgobject-2.0.so.0 => /lib64/libgobject-2.0.so.0 (0x00007f6f40d30000)
	libglib-2.0.so.0 => /lib64/libglib-2.0.so.0 (0x00007f6f40a52000)
	libc.so.6 => /lib64/libc.so.6 (0x00007f6f406e4000)
	libdb-4.7.so => /lib64/libdb-4.7.so (0x00007f6f40372000)
	libsasl2.so.2 => /usr/lib64/libsasl2.so.2 (0x00007f6f40158000)
	libssl.so.8 => /usr/lib64/libssl.so.8 (0x00007f6f3ff07000)
	libcrypto.so.8 => /usr/lib64/libcrypto.so.8 (0x00007f6f3fb83000)
	libz.so.1 => /lib64/libz.so.1 (0x00007f6f3f96e000)
	libkrb5.so.3 => /usr/lib64/libkrb5.so.3 (0x00007f6f3f6cf000)
	libk5crypto.so.3 => /usr/lib64/libk5crypto.so.3 (0x00007f6f3f4a9000)
	libcom_err.so.2 => /lib64/libcom_err.so.2 (0x00007f6f3f2a6000)
	libgssapi_krb5.so.2 => /usr/lib64/libgssapi_krb5.so.2 (0x00007f6f3f07a000)
	libgailutil.so.18 => /usr/lib64/libgailutil.so.18 (0x00007f6f3ee73000)
	libgnome-keyring.so.0 => /usr/lib64/libgnome-keyring.so.0 (0x00007f6f3ec5f000)
	/lib64/ld-linux-x86-64.so.2 (0x00007f6f4b730000)
	libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00007f6f3ea44000)
	libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00007f6f3e80d000)
	libusb-0.1.so.4 => /usr/lib64/libusb-0.1.so.4 (0x00007f6f3e605000)
	libbluetooth.so.3 => /usr/lib64/libbluetooth.so.3 (0x00007f6f3e3ed000)
	libgnutls.so.26 => /usr/lib64/libgnutls.so.26 (0x00007f6f3e143000)
	libgcrypt.so.11 => /lib64/libgcrypt.so.11 (0x00007f6f3ded0000)
	libuuid.so.1 => /lib64/libuuid.so.1 (0x00007f6f3dccc000)
	libavahi-glib.so.1 => /usr/lib64/libavahi-glib.so.1 (0x00007f6f3dac9000)
	libavahi-common.so.3 => /usr/lib64/libavahi-common.so.3 (0x00007f6f3d8bd000)
	libavahi-client.so.3 => /usr/lib64/libavahi-client.so.3 (0x00007f6f3d6ad000)
	libresolv.so.2 => /lib64/libresolv.so.2 (0x00007f6f3d494000)
	libselinux.so.1 => /lib64/libselinux.so.1 (0x00007f6f3d276000)
	libutil.so.1 => /lib64/libutil.so.1 (0x00007f6f3d073000)
	libORBitCosNaming-2.so.0 => /usr/lib64/libORBitCosNaming-2.so.0 (0x00007f6f3ce6d000)
	libm.so.6 => /lib64/libm.so.6 (0x00007f6f3cbe9000)
	libXfixes.so.3 => /usr/lib64/libXfixes.so.3 (0x00007f6f3c9e4000)
	libXext.so.6 => /usr/lib64/libXext.so.6 (0x00007f6f3c7d2000)
	libXrender.so.1 => /usr/lib64/libXrender.so.1 (0x00007f6f3c5c9000)
	libXinerama.so.1 => /usr/lib64/libXinerama.so.1 (0x00007f6f3c3c7000)
	libXi.so.6 => /usr/lib64/libXi.so.6 (0x00007f6f3c1bd000)
	libXrandr.so.2 => /usr/lib64/libXrandr.so.2 (0x00007f6f3bfb5000)
	libXcursor.so.1 => /usr/lib64/libXcursor.so.1 (0x00007f6f3bdab000)
	libXcomposite.so.1 => /usr/lib64/libXcomposite.so.1 (0x00007f6f3bba9000)
	libXdamage.so.1 => /usr/lib64/libXdamage.so.1 (0x00007f6f3b9a7000)
	libpng12.so.0 => /usr/lib64/libpng12.so.0 (0x00007f6f3b782000)
	libpixman-1.so.0 => /usr/lib64/libpixman-1.so.0 (0x00007f6f3b53d000)
	libexpat.so.1 => /lib64/libexpat.so.1 (0x00007f6f3b315000)
	libcap.so.2 => /lib64/libcap.so.2 (0x00007f6f3b111000)
	libkrb5support.so.0 => /usr/lib64/libkrb5support.so.0 (0x00007f6f3af08000)
	libkeyutils.so.1 => /lib64/libkeyutils.so.1 (0x00007f6f3ad06000)
	libXau.so.6 => /usr/lib64/libXau.so.6 (0x00007f6f3ab04000)
	libfreebl3.so => /lib64/libfreebl3.so (0x00007f6f3a8a6000)
	libtasn1.so.3 => /usr/lib64/libtasn1.so.3 (0x00007f6f3a695000)
	libgpg-error.so.0 => /lib64/libgpg-error.so.0 (0x00007f6f3a492000)
	libattr.so.1 => /lib64/libattr.so.1 (0x00007f6f3a28e000)
Comment 11 Milan Crha 2009-07-28 05:13:16 EDT
I wonder what I do differently from you.
When I set NTLM/SPA together with TLS, then IMAP on Exchange 2007 works fine for me. But if I use SSL or no encryption, then the NTLM/SPA is not working. Applies for both receiving and sending options.
Comment 12 Roger 2009-07-28 07:01:21 EDT
I should have been more explicit in what "the same problem" was.

Configurations that fail:
- Exchange 2007 server + IMAP + SSL transport + NTLM/SPA auth
- " + " + TLS + "

Configuration that works
- " + " + SSL + Password auth
Comment 13 Bug Zapper 2009-11-18 05:02:02 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 14 Bug Zapper 2009-12-18 04:27:02 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.