Bug 501256 - Toshiba M9 Laptop crashes when lid is closed or power state changes on Fedora 10
Toshiba M9 Laptop crashes when lid is closed or power state changes on Fedora 10
Status: CLOSED DUPLICATE of bug 464866
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
10
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-18 05:24 EDT by Greg Dolph
Modified: 2018-04-11 03:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-06 05:24:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Dolph 2009-05-18 05:24:38 EDT
Description of problem:
Toshiba Tecra M9 PTM91E crashes when laptop lid is closed or the power state changes. This happens with every kernel version installed so far, and all upgrades. I have set power management to do nothing when the lid is closed but this does not fix it. Shutting down acpid does nothing. When the lid is closed or I plug or unplug the external power the system becomes completely non-responsive; control-alt-f[1..8] doesn't work, neither does control-alt-esc or control-alt-del. The only solution is to shut down and restart using the power button. 

Version-Release number of selected component (if applicable):
this has happened on Fedora 10 kernels: 
2.6.27.7-134.fc10.x86_64, 2.6.27.9-159.fc10.x86_64, 2.6.27.12-170.2.5.fc10.x86_64, 2.6.27.21-170.2.56.fc10.x86_64

How reproducible:
every time. Sometimes the screen blanks, sometimes the pointer remains on a black screen, sometimes the background is still visible, but in each case it's just as dead. 

Steps to Reproduce:
1. close lid
2. open lid with trepidation
3. cry

Actual results:


Expected results:


Additional info:
Comment 1 Greg Dolph 2009-05-18 12:36:55 EDT
I can still SSH onto the system so I know that it's not a total crash. If I killall -9 Xorg X restarts and I can re-login. 

from the /var/log/Xorg.0.log:

EQ Overflowing. The server is probably stuck in an infinite loop!
Comment 2 Greg Dolph 2009-05-19 03:51:24 EDT
I can still SSH onto the system so I know that it's not a total crash. If I killall -9 Xorg X restarts and I can re-login. 

from the /var/log/Xorg.0.log:

EQ Overflowing. The server is probably stuck in an infinite loop!
Comment 3 Matěj Cepl 2009-05-21 09:00:06 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available), /var/log/dmesg, and COMPLETE X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 4 Vedran Miletić 2009-09-06 05:24:53 EDT
It's likely a duplicate of bug 464866.

*** This bug has been marked as a duplicate of bug 464866 ***

Note You need to log in before you can comment on or make changes to this bug.