Bug 501282 - preupgrade failure, luks encrypted root not found
preupgrade failure, luks encrypted root not found
Status: CLOSED DUPLICATE of bug 499321
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-18 07:33 EDT by Tomasz Torcz
Modified: 2009-05-18 09:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 09:13:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (9.71 KB, text/plain)
2009-05-18 07:33 EDT, Tomasz Torcz
no flags Details

  None (edit)
Description Tomasz Torcz 2009-05-18 07:33:16 EDT
Created attachment 344418 [details]
anaconda.log

Description of problem:
When I try preupgrade, after reboot anaconda can't find any installation. It doesn't ask for LUKS password, which it should. My disk layout:
/dev/sda1 /boot
/dev/sda2 luks-encrypted LVM with ext4 root (Fedora 10 amd64)

Situation is like that since about a week. Before anaconda was activating rootvg, but then crashing having found swap partitions.

Version-Release number of selected component (if applicable):
-rw-r--r-- 1 root root  19434876 maj 17 16:52 initrd.img
-rw-r--r-- 1 root root 116355072 maj 17 16:52 install.img


How reproducible:
Always.
Comment 1 Tomasz Torcz 2009-05-18 09:13:53 EDT
Using updates.img from #499321 fixes it.

*** This bug has been marked as a duplicate of bug 499321 ***

Note You need to log in before you can comment on or make changes to this bug.