Bug 5013 - Default prompt set to values ksh doesn't properly interpret
Default prompt set to values ksh doesn't properly interpret
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: pdksh (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-09-09 01:17 EDT by Jeremy Katz
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-16 12:40:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 1999-09-09 01:17:10 EDT
This is actually from Lorax, but the package is the same at
the present time (pdksh-5.2.14-1).

PS1 is set to be [\u@\h \W] but ksh isn't interpreting them
as special sequences and leaving that verbatim as the
prompt.  This is due to the fact that ksh reads /etc/profile
as it's startup file as well as bash and the two don't share
identical syntax.
Comment 1 Bill Nottingham 2000-02-16 12:40:59 EST
This will be fixed in setup-2.1.6, as the prompt will be set in /etc/bashrc.

Note You need to log in before you can comment on or make changes to this bug.