Bug 501338 - Error condition is not cleared
Error condition is not cleared
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-18 12:02 EDT by Mads Kiilerich
Modified: 2009-10-08 10:00 EDT (History)
4 users (show)

See Also:
Fixed In Version: 3.9.8-12.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-31 19:30:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
system-config-printer troubleshooting (95.56 KB, text/plain)
2009-08-23 17:38 EDT, John Thacker
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 418030 None None None Never
Launchpad 418053 None None None Never

  None (edit)
Description Mads Kiilerich 2009-05-18 12:02:58 EDT
Description of problem:

I don't know the details, but I have bad use case, seen with both a USB HPLIP printer and a network attached HP printer: 

After an out-of-paper error a warning sign and error message is shown by some applet. But even after the problem has been resolved and the printer works again then the icon remains.

Restarting cups seems to cause the printer queue to work again. Sometimes.


Version-Release number of selected component (if applicable):

cups-1.4-0.b2.17.fc11.i586
system-config-printer-1.1.7-4.fc11.i586
Comment 1 Tim Waugh 2009-06-04 11:19:56 EDT
There are two things here:

1. the out-of-paper indication
2. the print queue actually not working

The out-of-paper noticiation, i.e. the 'media-empty-error' value in the printer-state-reasons IPP attribute for the queue, will not prevent the queue from working.  Something else is going on if your queue is rejecting jobs or something.

Can you elaborate on "cause the printer queue to work again"? How is it not working?  What does 'lpstat -t' say at that point?
Comment 2 Mads Kiilerich 2009-06-07 14:32:13 EDT
This time I ran out of paper and got a notification icon with a popup message:
Out of paper
Printer 'HP_LaserJet_P1005' is out of paper.

$ lpstat -t
scheduler is running
system default destination: HP_LaserJet_P1005
device for HP_LaserJet_P1005: hp:/usb/HP_LaserJet_P1005?serial=BC123PQ
HP_LaserJet_P1005 accepting requests since Sun 07 Jun 2009 07:59:43 PM CEST
printer HP_LaserJet_P1005 now printing HP_LaserJet_P1005-0.  enabled since Sun 07 Jun 2009 07:59:43 PM CEST
HP_LaserJet_P1005-42    mk              126976   Sun 07 Jun 2009 07:59:43 PM CEST

Turning printer off, inserting paper, and turning printer on doesn't change the lpstat message or anything else.

Clicking the printer error notification icon I get "Document Print status (my jobs)" window showing Status "Processing" for a stdin job. The context menu only allows me to cancel. When making another print-out it waits in the queue as Pending. Cancelling the stuck job makes the printer print the new job, and the bottom line in the status window no longer says "Out of paper". But the notification message doesn't disappear. Only when I close the notification message then the notification icon disappears.

Is this expected behaviour?

I would expect that turning the printer off and fix the problem and turn it on would get me back to a working behaviour - with or without the failing job.

As mentioned before: I think I have seen other behaviour with even more persistent error messages other times. This is with HPLIB which might be strange, but I have seen apparently the same behaviour with a network lpr HP 2430 PS (IIRC).

I am not familiar with the modern printing subsystem, but I can probably help with some low-level debugging if you give me some hints.
Comment 3 Mads Kiilerich 2009-06-07 14:34:34 EDT
And when I print again and the printer notification thus is shown then it has an error indication and when hoovering over it still says "out of paper".
Comment 4 Tim Waugh 2009-06-08 05:12:38 EDT
The way it's meant to work is that once the driver sees the error condition is cleared it tells CUPS all is fine and continues with the job; then system-config-printer spots it and removes the error icon.

I think that the job applet is occasionally missing some event notifications from cups, judging by other reports (but I haven't yet had the time to investigate).  If you click on the error icon to get the job list displayed and select View->Refresh from the menu bar, does that clear the error?
Comment 5 Bug Zapper 2009-06-09 12:03:15 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 John Thacker 2009-08-22 02:58:41 EDT
I have the same problem, with an HP Deskjet 6940 (connected over Ethernet)

Selecting View->Refresh from either the job list or the printer configuration window does not clear the error.

The error persisted after a reboot of the machine and after rebooting the printer.  I get exactly the same behavior as the reporter.  The out-of-paper notification icon now appears every time I print, though printing works fine.
Comment 7 Tim Waugh 2009-08-22 06:03:18 EDT
OK, this definitely seems like a driver problem then, and not some bug in system-config-printer.

John: please run the printing troubleshooter (System->Administration->Printing, then Help->Troubleshoot) and attach the resulting troubleshoot.txt using the 'Add an attachment' link on this page.  I need to see which driver is being used, what state reasons it has set, and when.  Thanks.
Comment 8 John Thacker 2009-08-23 17:38:46 EDT
Created attachment 358387 [details]
system-config-printer troubleshooting

Requested troubleshooting log
Comment 9 Fedora Update System 2009-08-25 18:13:27 EDT
hplip-3.9.8-9.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6959
Comment 10 Fedora Update System 2009-08-26 22:10:41 EDT
hplip-3.9.8-10.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6959
Comment 11 John Thacker 2009-08-26 23:24:59 EDT
The update fixes it for me, thanks!
Comment 12 Fedora Update System 2009-08-28 17:57:21 EDT
hplip-3.9.8-12.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6959
Comment 13 Fedora Update System 2009-08-31 19:29:53 EDT
hplip-3.9.8-12.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 James 2009-10-08 09:44:11 EDT
I am having similar problems with Fedora 11 and all the current updates installed. My printer was out of paper at one point, and now the error status is no longer updated even though the printer is ok and I have even rebooted my computer. Printing does not work either. My printer is HP Laserjet 1320n, and I am connected to the printer via the network.

I tried to run su -c 'yum --enablerepo=updates-testing update hplip' but no new packages were installed. My hplip version is

hplip.i586                        3.9.8-12.fc11
Comment 15 James 2009-10-08 10:00:15 EDT
I was able to fix the problem. The problem was that because the printer had been out of paper at one point, the printer had been disabled. Enabling the printer cleared the error condition, and now printing works again. However, I would like to point out that the job appled said "Printer out of paper" all the time, even when the real problem was that the printer was disabled.

Note You need to log in before you can comment on or make changes to this bug.