Bug 501342 - RE_ENROLL does not reset after a re-enrollment is done.
RE_ENROLL does not reset after a re-enrollment is done.
Status: CLOSED NOTABUG
Product: Dogtag Certificate System
Classification: Community
Component: TPS (Show other bugs)
unspecified
All Linux
low Severity high
: ---
: ---
Assigned To: Christina Fu
Chandrasekar Kannan
:
Depends On:
Blocks: 445047
  Show dependency treegraph
 
Reported: 2009-05-18 12:09 EDT by Sean Veale
Modified: 2015-01-04 18:38 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-15 12:22:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Veale 2009-05-18 12:09:46 EDT
Description of problem:

IF the RE_ENROLL flag was original set to NO and then an TPS Agent set the flag to YES after one enrollment the flag should reset back to NO. This is not happening for RE_ENROLL.  

Works correctly for PIN_RESET


Version-Release number of selected component (if applicable):

CS 8.0 Beta 2

How reproducible:
Always

Steps to Reproduce:
1.Set the default Renroll and Pin reset flags to NO in the tps CS.cfg files
2.Enroll a token. Have a TPS agent change the RE_ENROLL flag from No to YES.
3.Re-enroll the token.  That works. 
4. Check the Flag status and notice RE_ENROLL is not reset back to NO
  
Actual results:
Can re-enroll as many times as you want to

Expected results:
Can only re-enroll once

Additional info:

Pin reset works fine
Comment 1 Christina Fu 2009-05-19 11:55:07 EDT
just for the record:

The behaviour is as expected by design.  This is a policy that allows
the agent to set for the token whether re-enrollment is allowed or not.
There is no implication in the design to allow this re-enollment to take
place only once.
Although I could see the use for it.

Note You need to log in before you can comment on or make changes to this bug.