Bug 501360 - sgml-common.spec lacks Requires: /bin/basename
sgml-common.spec lacks Requires: /bin/basename
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sgml-common (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-18 14:04 EDT by Bruce Jerrick
Modified: 2009-05-19 09:37 EDT (History)
1 user (show)

See Also:
Fixed In Version: sgml-common-0.6.3-28.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-19 09:37:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruce Jerrick 2009-05-18 14:04:57 EDT
Description of problem:
The postinstall scriptlets of packages using /usr/bin/install-catalog fails
during Fedora 11 OS installation.

Version-Release number of selected component (if applicable):
sgml-common-0.6.3-27.fc11

How reproducible:
Depends on the exact package mix.  Always happens if sgml-common
gets installed before coreutils .

Steps to Reproduce:
1. Install Fedora 11 OS, with sgml-common and html401-dtds included.
2. grep -A 3 "Installing html401-dtds" /root/install.log

(html401-dtds postinstall triggers the bug)
  
Actual results:
Installing html401-dtds-4.01-19991224.9.noarch
/usr/bin/install-catalog: line 14: basename: command not found
/usr/bin/install-catalog: line 133: basename: command not found
/usr/bin/install-catalog: line 143: basename: command not found

Expected results:
No error message in /root/install.log .

Additional info:
The problem is evident from examination of /usr/bin/install-catalog and the
spec file of sgml-common .  /usr/bin/install-catalog (part of sgml-common)
uses basename, but sgml-common.spec does not have a Requires entry that
reflects that dependency.  The bug is triggered by the installation of
html401-dtds -- its postinstall scriptlet calls /usr/bin/install-catalog .

The fix is to add this to sgml-common.spec:

    Requires:      /bin/basename
Comment 1 Ondrej Vasik 2009-05-19 09:37:01 EDT
Thanks for report, fixed and built in rawhide as sgml-common-0.6.3-28.fc12 . Not sure what to do with F-11 and lower sgml-common's - as update doesn't solve much (problem usually appears only for installation - otherwise coreutils/busybox are present on almost every machine). Closing RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.