Bug 501386 - DNS settings are cleared on system restart
DNS settings are cleared on system restart
Status: CLOSED DUPLICATE of bug 499344
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-18 17:01 EDT by bruce
Modified: 2009-05-21 20:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-21 20:43:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bruce 2009-05-18 17:01:49 EDT
Description of problem:
DNS settings, to appear in resolv.conf, are cleared to nothing on system boot.

Version-Release number of selected component (if applicable):
system-config-network 1.5.93 is where I see the results.
I assume the bug is actually in NetworkManager, but don't know exactly.

How reproducible:
Use the GUI to set the DNS, then reboot.  Fails every time.

Steps to Reproduce:
1.Go to System, Administration, Network, click on DNS tab, enter primary and secondary DNS addresses.
2. Save configuration.  You will see it in both the default resolv.conf and /etc/resolv.conf .
3. Shutdown restart the system.
  
Actual results:
DNS will be missing in all places mentioned.
No commands, such as "host", that try to access DNS will work.

Expected results:
The DNS IP addresses entered will remain so, and show up in resolv.conf .

Additional info:
NetworkManager is running, one interface is activated and controlled by it.
Comment 1 bruce 2009-05-20 03:25:31 EDT
1. There is another bug reported in which the DNS settings are lost.
2. The bug does not occur if NetworkManager is disabled.
3. There is another bug in which interfaces do not activate on boot, unless they are controlled by NetworkManager.  It is reported by another user that the bug does not occur if NetworkManager is uninstalled.  Merely disabling it does not fix that problem.

Hint: NetworkManager needs serious attention or even removal from the distribution.
Comment 2 Niels Haase 2009-05-21 20:43:45 EDT
Thank you for the bug report. This particular bug has already been reported into our bug tracking system, but please feel free to report any further bugs you find.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 499344 ***

Note You need to log in before you can comment on or make changes to this bug.