Bug 501423 - Thunderbird or Firefox don't shutdown and often must be killed to restart
Thunderbird or Firefox don't shutdown and often must be killed to restart
Status: CLOSED DUPLICATE of bug 501427
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-18 23:38 EDT by gene smith
Modified: 2009-05-25 18:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-25 18:58:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Here is info requested for ff crash/lockup in KDE (28.78 KB, text/plain)
2009-05-24 19:35 EDT, gene smith
no flags Details
Info for thunderbird lockup (12.21 KB, text/plain)
2009-05-24 19:59 EDT, gene smith
no flags Details
Fixed the descriptions: 1st is crash, followed by lock-up. (28.85 KB, text/plain)
2009-05-24 20:07 EDT, gene smith
no flags Details

  None (edit)
Description gene smith 2009-05-18 23:38:02 EDT
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1b4) Gecko/20090427 Fedora/3.5-0.20.beta4.fc11 Firefox/3.5b4

If Thunderbird or Firefox program is closed or shutdown and then restarted a message appears saying "Thunderbird(Firefox) is already running, but is not responding. To open a new window, you must first close the existing Thunderbird(Firefox) process, or restart your system." You must do something like "killall -9 thunderbird-bin(firefox)" to restart Thunderbird or Firefox.

Reproducible: Sometimes

Steps to Reproduce:
1.Start firefox (or thunderbird)
2.Shutdown firefox (x at top right or File|Close or ctrl-Q
3.Firefox (or thunderbird) appears to shutdown
4.When attempt to restart, message "Firefox(Thunderbird) is already running ..."
5.Must Kill firefox or thunderbird.
6.Can now successfully restart firefox (or thunderbird)
Actual Results:  
Firefox or thunderbird restarts (but only after previous instance is manually killed after a typical user shutdown).

Expected Results:  
Should be able to start and shutdown firefox or thunderbird without having to kill -9 them.
Comment 1 gene smith 2009-05-21 23:05:32 EDT
FWIW, for my install, firefox and thunderbird stop and start OK in gnome with no problem. The problem only occurs in KDE.
Comment 2 Matěj Cepl 2009-05-23 20:01:25 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

First of all, could we get output of the command

	rpm -qa *xulrun* *firefox* *thunderbird* *mozilla* *flash* *plugin*

Please also install firefox-debuginfo and thunderbird-debuginfo (debuginfo-install is from yum-utils package).

	debuginfo-install firefox
        debuginfo-install thunderbird

Then run firefox (or thunderbird) with a parameter -g. That will start firefox running inside of gdb debugger. Then use command run and do whatever you did to make firefox crash. When it happens, you should go back to the gdb and run

	(gdb) thread apply all backtrace

This produces usually many screens of the text. Copy all of them into a text editor and attach the file to the bug as an uncompressed attachment.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 gene smith 2009-05-24 19:35:19 EDT
Created attachment 345268 [details]
Here is info requested for ff crash/lockup in KDE

Here is the info you requested for when I shutdown firefox and it will not restart in KDE. I will send similar information regarding thunderbird.
Comment 4 gene smith 2009-05-24 19:59:44 EDT
Created attachment 345269 [details]
Info for thunderbird lockup

Here is the same information for thunderbird. Usually on closing thunderbird, it hangs and doesn't shutdown completely. But sometimes it crashes when shutdown. The trace shown is for a crash. It appears to be the same information as I provided when firefox shuts down (I guess since thunderbird uses firefox components to display the "start" page).

Note: My previous attachment I had the description of the traces backward between the lockup case and the crash case.
Comment 5 gene smith 2009-05-24 20:07:01 EDT
Created attachment 345270 [details]
Fixed the descriptions: 1st is crash, followed by lock-up.

Set as plain text so easy to view (sorry). Also, corrected my descriptions.
Comment 6 gene smith 2009-05-25 15:40:28 EDT
Found a workaround for the problem. See bug 501427 which is essentially a duplicate of this.
Comment 7 Matěj Cepl 2009-05-25 18:58:38 EDT
(In reply to comment #6)
> Found a workaround for the problem. See bug 501427 which is essentially a
> duplicate of this.  

Is it? Well, if you say so. Closing as duplicate.

*** This bug has been marked as a duplicate of bug 501427 ***

Note You need to log in before you can comment on or make changes to this bug.