Bug 501522 - RFE: Provide QMF model using qpid transport for ricci
RFE: Provide QMF model using qpid transport for ricci
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ricci (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Chris Feist
Cluster QE
FutureFeature
: FutureFeature
: 555140 (view as bug list)
Depends On:
Blocks: 501519
  Show dependency treegraph
 
Reported: 2009-05-19 11:05 EDT by Perry Myers
Modified: 2011-09-13 11:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-21 12:03:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Perry Myers 2009-05-19 11:05:45 EDT
Description of problem:
Presently ricci uses a proprietary comms interface for communication with the luci server portion of conga.  It would be better to move to a standard interface like QMF/qpid so that we have interoperability with other management infrastructure operating on the qpid bus.

This bug is to provide a QMF model that captures all of the current actions that can be done by the various ricci modules and to implement that as part of the ricci agent so that the ricci agent becomes a qpid agent.
Comment 1 RHEL Product and Program Management 2009-05-19 11:24:57 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Perry Myers 2010-11-27 13:01:47 EST
*** Bug 555140 has been marked as a duplicate of this bug. ***
Comment 5 Chris Feist 2011-02-21 12:03:39 EST
Closing as WONTFIX as there is no reason to add another transport to ricci when it will be replaced by matahari.

Note You need to log in before you can comment on or make changes to this bug.