Bug 501542 - Dead Keys and input methods (e.g. SCIM) still not working with Qt Apps
Dead Keys and input methods (e.g. SCIM) still not working with Qt Apps
Status: CLOSED DUPLICATE of bug 468590
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-19 12:57 EDT by DemetrisK
Modified: 2009-05-19 13:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-19 13:04:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description DemetrisK 2009-05-19 12:57:58 EDT
User-Agent:       Opera/9.63 (X11; Linux i686; U; en) Presto/2.1.1

This bug was reported against Fedora 10 but still exists in Fedora 11 Rawhide.
When using GNOME desktop and you use Qt3/4 apps, you can't use Dead Keys (for languages like Greek, French etc) or SCIM, Ibus etc for Asian languages. 

Reproducible: Always

Steps to Reproduce:
1. Install GNOME and a Keyboard layout that uses some kind of dead keys or an Asian language that requires an IM
2. Open a Qt app and try to input modified characters (for Greek, try ' + α) or use SCIM
3.
Actual Results:  
' + α produces 'α
IM won't load with non-GTK apps.

Expected Results:  
' + α should produce ά
IM method should allows the user to input complex script.

Dead keys will work with Qt apps ONLY if you are root (su - or sudo)
Comment 1 Kevin Kofler 2009-05-19 13:04:32 EDT

*** This bug has been marked as a duplicate of bug 468590 ***

Note You need to log in before you can comment on or make changes to this bug.