Bug 501543 - kmod-kvm: load modules on %post
kmod-kvm: load modules on %post
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.4
All Linux
low Severity low
: rc
: ---
Assigned To: Eduardo Habkost
Lawrence Lim
:
: 489947 (view as bug list)
Depends On:
Blocks: Rhel5KvmTier3 5.4/TechnicalNotes 57KnownIssue
  Show dependency treegraph
 
Reported: 2009-05-19 13:17 EDT by Eduardo Habkost
Modified: 2014-03-25 20:56 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The KVM modules available in the kmod-kvm package are loaded automatically at boot time if the kmod-kvm package is installed. To make these KVM modules available after installing the kmod-kvm package the system either needs to be rebooted or the modules can be loaded manually by running the /etc/sysconfig/modules/kvm.modules script.
Story Points: ---
Clone Of: 489947
Environment:
Last Closed: 2011-01-13 14:32:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eduardo Habkost 2009-05-19 13:17:03 EDT
+++ This bug was initially created as a clone of Bug #489947 +++

The kvm package installs a /etc/sysconfig/modules/kvm.modules file, to load the KVM modules on boot. We should do that on %post also, so the modules are loaded automatically without rebooting the machine.
Comment 2 Eduardo Habkost 2009-06-04 12:27:15 EDT
A better fix would be making the kmodtool script used by the many kmod packages able to handle loading of the modules at RPM-install time, instead of making a kvm-specific fix.
Comment 3 Eduardo Habkost 2009-06-04 12:30:14 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
The KVM modules available on the kmod-kvm package are loaded automatically at boot time if the kmod-kvm package is installed. After installing the kmod-kvm package, the system needs to be rebooted or, alternatively, the modules may be loaded manually (kvm-intel or kvm-amd, plus the ksm module).
Comment 4 Eduardo Habkost 2009-06-04 13:35:25 EDT
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1 +1 @@
-The KVM modules available on the kmod-kvm package are loaded automatically at boot time if the kmod-kvm package is installed. After installing the kmod-kvm package, the system needs to be rebooted or, alternatively, the modules may be loaded manually (kvm-intel or kvm-amd, plus the ksm module).+The KVM modules available on the kmod-kvm package are loaded automatically at boot time if the kmod-kvm package is installed. After installing the kmod-kvm package, the system needs to be rebooted or, alternatively, the modules may be loaded manually by running the /etc/sysconfig/modules/kvm.modules script.
Comment 6 Ryan Lerch 2009-08-17 23:29:07 EDT
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1 +1 @@
-The KVM modules available on the kmod-kvm package are loaded automatically at boot time if the kmod-kvm package is installed. After installing the kmod-kvm package, the system needs to be rebooted or, alternatively, the modules may be loaded manually by running the /etc/sysconfig/modules/kvm.modules script.+The KVM modules available in the kmod-kvm package are loaded automatically at boot time if the kmod-kvm package is installed. To make these KVM modules available after installing the kmod-kvm package the system either needs to be rebooted or the modules can be loaded manually by running the /etc/sysconfig/modules/kvm.modules script.
Comment 10 Eduardo Habkost 2010-09-01 17:30:07 EDT
*** Bug 489947 has been marked as a duplicate of this bug. ***
Comment 11 RHEL Product and Program Management 2011-01-11 15:45:29 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 12 RHEL Product and Program Management 2011-01-11 17:46:05 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.

Note You need to log in before you can comment on or make changes to this bug.