Bug 501577 - `/etc/init.d/puppet status` returns errors
`/etc/init.d/puppet status` returns errors
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: puppet (Show other bugs)
el4
All Linux
low Severity medium
: ---
: ---
Assigned To: Todd Zullinger
Fedora Extras Quality Assurance
ActualBug
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-19 15:46 EDT by Aaron Dummer
Modified: 2009-09-12 13:54 EDT (History)
6 users (show)

See Also:
Fixed In Version: 0.24.8-4.el4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-11 19:24:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
remove '-p' option from status function (268 bytes, patch)
2009-05-19 15:48 EDT, Aaron Dummer
no flags Details | Diff
Check that status accepts a -p option before using it (855 bytes, patch)
2009-05-20 21:21 EDT, Todd Zullinger
no flags Details | Diff

  None (edit)
Description Aaron Dummer 2009-05-19 15:46:49 EDT
Description of problem:
`/etc/init.d/puppet status` doesn't work


Version-Release number of selected component (if applicable):
0.24.8-1.1


How reproducible:
always


Steps to Reproduce:
Run `/etc/init.d/puppet status`
  

Actual results:
pidof: invalid options on command line!

pidof: invalid options on command line!

-p is stopped


Expected results:
puppetd (pid 1286) is running...

or

puppetd is stopped


Additional info:
The error occurs because RHEL4 doesn't support the -p option in the status function used by the init script.  The status function is defined in /etc/rc.d/init.d/functions.  RHEL5 does support -p.

I attached a patch which fixes the problem.  It should only be applied to the RHEL4 package.
Comment 1 Aaron Dummer 2009-05-19 15:48:44 EDT
Created attachment 344673 [details]
remove '-p' option from status function
Comment 2 Jeroen van Meeuwen 2009-05-20 14:41:32 EDT
Confirmed, working on this rightaway
Comment 3 Todd Zullinger 2009-05-20 21:21:15 EDT
Created attachment 344904 [details]
Check that status accepts a -p option before using it

FWIW, this was caused by upstream commit 7f5ded18 (Fixed #1646 - service puppet status does not work as non-root on redhat system).

http://github.com/reductivelabs/puppet/commit/7f5ded185269cabeb7921c4f4739e1f66a34d54d

http://projects.reductivelabs.com/issues/show/1646

We can tease lutter about not testing that upstream patch well enough. ;)

Ideally, the init script can be made to test whether status has the -p option, so that it works on older EL releases, as well as newer EL and Fedora.  Perhaps the attached patch isn't too ugly to be used and submitted upstream?
Comment 4 Jeroen van Meeuwen 2009-05-31 08:23:13 EDT
Nice patch, +1 to have this go upstream
Comment 5 Todd Zullinger 2009-05-31 15:21:28 EDT
I submitted this to puppet-dev today.  I'll assign this to me so I remember to update/close it when we have a fixed package.
Comment 6 Michael Stahnke 2009-06-17 18:34:47 EDT
Upstream bug URL

http://projects.reductivelabs.com/issues/2123
Comment 7 Fedora Update System 2009-08-10 11:04:17 EDT
puppet-0.24.8-4.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/puppet-0.24.8-4.fc10
Comment 8 Fedora Update System 2009-08-10 11:04:42 EDT
puppet-0.24.8-4.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/puppet-0.24.8-4.el5
Comment 9 Fedora Update System 2009-08-10 11:05:06 EDT
puppet-0.24.8-4.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/puppet-0.24.8-4.fc11
Comment 10 Fedora Update System 2009-08-10 11:05:31 EDT
puppet-0.24.8-4.el4 has been submitted as an update for Fedora EPEL 4.
http://admin.fedoraproject.org/updates/puppet-0.24.8-4.el4
Comment 11 Fedora Update System 2009-08-11 16:37:01 EDT
puppet-0.24.8-4.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update puppet'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/EL-5/FEDORA-EPEL-2009-0262
Comment 12 Fedora Update System 2009-08-11 16:37:30 EDT
puppet-0.24.8-4.el4 has been pushed to the Fedora EPEL 4 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update puppet'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/EL-4/FEDORA-EPEL-2009-0253
Comment 13 Fedora Update System 2009-08-11 18:33:59 EDT
puppet-0.24.8-4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update puppet'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8477
Comment 14 Fedora Update System 2009-08-11 18:38:24 EDT
puppet-0.24.8-4.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update puppet'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-8494
Comment 15 Fedora Update System 2009-09-11 19:23:57 EDT
puppet-0.24.8-4.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2009-09-11 19:36:43 EDT
puppet-0.24.8-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2009-09-12 13:52:05 EDT
puppet-0.24.8-4.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2009-09-12 13:53:37 EDT
puppet-0.24.8-4.el4 has been pushed to the Fedora EPEL 4 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.