Bug 501580 - PartitionException: Attempting to remove an extended partition that still contains logical partitions
PartitionException: Attempting to remove an extended partition that still con...
Status: CLOSED DUPLICATE of bug 500808
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:24a553617e0483759...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-19 16:23 EDT by James Laska
Modified: 2013-09-02 02:36 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-19 16:26:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (152.24 KB, text/plain)
2009-05-19 16:23 EDT, James Laska
no flags Details
Attached traceback automatically from anaconda. (161.30 KB, text/plain)
2009-05-28 11:56 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2009-05-19 16:23:51 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.53 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/site-packages/parted/disk.py", line 200, in removePartition
    if self.__disk.remove_partition(partition.getPedPartition()):
  File "/usr/lib/anaconda/storage/devices.py", line 773, in removePartition
    self.partedDisk.removePartition(partition)
  File "/usr/lib/anaconda/storage/devices.py", line 1262, in destroy
    self.disk.removePartition(self)
  File "/usr/lib/anaconda/storage/deviceaction.py", line 218, in execute
    self.device.destroy()
  File "/usr/lib/anaconda/storage/devicetree.py", line 671, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 238, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 117, in turnOnFilesystems
    anaconda.id.storage.doIt()
PartitionException: Attempting to remove an extended partition that still contains logical partitions
Comment 1 James Laska 2009-05-19 16:23:55 EDT
Created attachment 344687 [details]
Attached traceback automatically from anaconda.
Comment 2 James Laska 2009-05-19 16:25:10 EDT
= steps to reproduce = 
On kvm/x86_64 guest ... https://fedoraproject.org/wiki/QA:Testcase_Anaconda_autopart_(encrypted)_install

Select "Use entire disk"
Comment 3 Chris Lumens 2009-05-19 16:26:30 EDT

*** This bug has been marked as a duplicate of bug 500808 ***
Comment 4 James Laska 2009-05-28 11:56:22 EDT
Created attachment 345786 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.