Bug 501585 - Prompted to migrated existing F-10 ext3 '/' partition on upgrade to F-11 ... didn't boot with ext4migrate
Prompted to migrated existing F-10 ext3 '/' partition on upgrade to F-11 ... ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11AnacondaBlocker
  Show dependency treegraph
 
Reported: 2009-05-19 16:45 EDT by James Laska
Modified: 2013-09-02 02:36 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-29 10:56:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda.log (32.81 KB, text/plain)
2009-05-19 16:45 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2009-05-19 16:45:59 EDT
Created attachment 344700 [details]
anaconda.log

Description of problem:

Upgrading an F-10 install to Fedora 11 (anaconda-11.5.0.53) prompted '/' filesystem migration (http://jlaska.fedorapeople.org/fs-update.png).   I've never seen this prompt before. 

I did *not* boot with "ext4migrate"

Version-Release number of selected component (if applicable):

 * anaconda-11.5.0.53

How reproducible:

 * Seeing this on 3 attempts so far

Steps to Reproduce:
1. Install F-10 autopart
2. Boot F-11 (anaconda-11.5.0.53) 
3. Select existing "F-10" partition to upgrade
  
Actual results:

 * Prompted to migrate existing ext3 '/' partition to ext4

Expected results:

 * Never seen this prompt before ... is this expected?

Additional info:

 * http://jlaska.fedorapeople.org/fs-update.png
Comment 1 James Laska 2009-05-20 08:48:50 EDT
Does anyone know if this is an expected behavior?  It's okay if it is, this was just the first time I've seen (and tested) that screen when testing upgrades in Fedora 11.  I wanted to be sure before we release.
Comment 2 Chris Lumens 2009-05-20 10:20:21 EDT
You should only be offered this screen if you have ext4migrate on the command line.
Comment 3 Chris Lumens 2009-05-20 10:51:20 EDT
This will be fixed in anaconda-11.5.0.55-1, should we build that for F11.
Comment 4 James Laska 2009-05-20 11:01:54 EDT
I think so, it's a screen that isn't intended for general consumption and hasn't received focused testing.  My sense is having this the default behavior should be held off until post-F11.

Jesse, your thoughts from a rel-eng perspective?
Comment 5 Jesse Keating 2009-05-20 13:52:48 EDT
I agree, this should only show up with the cli argument.
Comment 6 James Laska 2009-05-29 10:56:07 EDT
Confirmed fix in anaconda-11.5.0.56

Note You need to log in before you can comment on or make changes to this bug.