Bug 501606 - yum 3.2.22-5 breaks livecd-creator/python-imgcreate
yum 3.2.22-5 breaks livecd-creator/python-imgcreate
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-19 21:08 EDT by Chris Shoemaker
Modified: 2014-01-21 18:09 EST (History)
8 users (show)

See Also:
Fixed In Version: 3.2.23-3.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-04 14:58:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Shoemaker 2009-05-19 21:08:58 EDT
Description of problem:
After upgrading to yum-3.2.22-5-fc11 I can no longer create a livecd with
livecd-creator.  It always fails to unmount the image because there are still
files open on the image.  Specifically $INSTALL_ROOT/var/lib/rpm/{Packages,Name,__db.00{1,2,3,4}} are still open.

python-imgcreate contains code to do:
  ayum.closeRpmDB()
  ayum.close()

with yum 3.2.22-4, this was sufficient to close all the rpm files, and
continue to unmount the image.  Reverting to yum-3.2.22-4 fixes the problem.

How reproducible:
100%

Steps to Reproduce:
1. install yum-3.2.22-5 and livecd-tools from f11
2. run livecd-creator with --shell
3. when the shell opens, the image should be unmountable, but do:
    $ lsof | grep imgcreate
   to see the files that remain open.
4. exit the shell anyway
5. note the failure messages from umount
6. watch livecd-creator forge ahead anyway, trying to resize the mounted image.
7. revert to yum-3.2.22-4 and try again.
8. in the shell, notice that all the files have been closed.
9. see how umount actually works.
10. enjoy a livecd.
Comment 1 seth vidal 2009-05-19 21:25:38 EDT
I just built a 3.2.23 for rawhide  -can you give that a try to see if that corrects the problem at all?

While I look through the changelogs to see if anything would cause this.
Comment 2 James Antill 2009-05-19 22:44:55 EDT
 I think I can guess what the problem is, can you try adding:

 ayum.rpmdb.ts = None

...and see if that solves the problem?
Comment 3 James Antill 2009-05-19 22:46:02 EDT
Note that "del ayum" will also work, and is probably future proof ... but assuming the above fixes it, we'll also have a fix 3.2.23-1 so the old code works.
Comment 4 Bruno Wolff III 2009-05-20 11:38:40 EDT
I am also seeing this and am getting messages from rpmdb at the end that seems likely to also be related. However this isn't blocking creating isos. If that is happening to you, it is probably the e2fsprogs issue described in bug 499452. There is an srpm in that bug that has a proposed fix that seems to be working for me. Presumably that will get pushed out soon.
Comment 5 Chris Shoemaker 2009-05-20 12:45:04 EDT
I tried all 3 suggestions, and none helped.

1) I reinstalled yum-3.2.22-5 and added "ayum.rpmdb.ts = None" just before ayum.close().  Same failure, same files still open.

2) I added "del ayum" after ayum.close().  Same failure again.

3) I upgraded yum to 3.2.23-1, (and left the above changes in place).
Same failure again.

@bruno, before I discovered that reverting yum fixed the problem, I got the e2fsprogs-1.41.4-9.fc11 because of bug 499452, just in case.  It didn't make any difference.
Comment 6 Jeremy Katz 2009-05-20 13:25:57 EDT
I can confirm it.  James -- setting the ts to None isn't helping either
Comment 7 Bruno Wolff III 2009-05-20 13:42:41 EDT
There is an additional update after e2fsprogs-1.41.4-9.fc11 as the fix in that apparently didn't fix everything. So you still might still need another update there.
However it does look like this bug can cause intermittent failures as well. After my last update to bug 499452, Katz said it looked like my remaining problems were due to this bug, not that one.
Comment 8 Jeremy Katz 2009-05-20 16:56:16 EDT
James committed a fix (which I tested) for this upstream.  Just need to make sure that's included before pushing anything newer to f11 :)
Comment 9 seth vidal 2009-05-20 17:25:36 EDT
and yum with the committed patch is building in koji now:
yum-3.2.23-2.fc11 (and fc12) and soon fc10
Comment 10 Bruno Wolff III 2009-05-20 18:08:22 EDT
I am currently only seeing the f12 version. I don't need it right away, but just wanted to note it in case something went wrong.
Comment 11 seth vidal 2009-05-20 18:28:07 EDT
3.2.23-3.fc11 - I forgot to actually commit the patch the first time :)
Comment 12 Bruno Wolff III 2009-05-21 08:17:18 EDT
I tried running livecd-creator with yum-3.2.23-3.fc11 on i386 and x86_64 and both seemed to work fine. I didn't try actually booting the resulting images, but the image sizes looked reasonable and nothing in the terminal output looked unusual. So it looks fixed here.
Comment 13 Fedora Update System 2009-05-21 11:32:08 EDT
yum-3.2.23-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/yum-3.2.23-3.fc10
Comment 14 Fedora Update System 2009-05-21 11:33:54 EDT
yum-3.2.23-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/yum-3.2.23-3.fc11
Comment 15 Fedora Update System 2009-05-25 17:18:07 EDT
yum-3.2.23-3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yum'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-5328
Comment 16 Fedora Update System 2009-05-25 17:24:49 EDT
yum-3.2.23-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yum'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-5413
Comment 17 Chris Shoemaker 2009-05-30 00:13:24 EDT
I confirm, bug is fixed in yum-3.2.23-3.fc11.noarch.
Comment 18 Fedora Update System 2009-06-15 21:25:34 EDT
yum-3.2.23-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2009-06-15 21:34:05 EDT
yum-3.2.23-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Alexander Todorov 2009-08-04 08:57:17 EDT
Hi,
I still have this problem with:
yum-3.2.23-3.fc11.noarch
e2fsprogs-1.41.4-10.fc11.i586

This is fully updated F11 system from today. The rootfs type in livecd is ext3.
It is reproducible every single time for me.
Comment 21 danz 2009-08-09 02:45:49 EDT
I had the same problem which was reproducible every time. 
but it went away after I had a update to e2fsprogs today.
e2fsprogs-libs-1.41.4-12.fc11.i586.rpm

Note You need to log in before you can comment on or make changes to this bug.