This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 50162 - missing requirement in rpm package
missing requirement in rpm package
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: krb5 (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-27 10:39 EDT by Roel van Meer
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-27 10:39:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Roel van Meer 2001-07-27 10:39:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; U; Linux 2.2.18 i686)

Description of problem:
the krb5-libs rpm uses grep in its postinstall script, but has
no dependancy on grep, which provides grep.
When installing a custom system with anaconda, chances are that krb5-libs
gets installed _before_ grep does, so the postinstall script will fail.
In this case, /usr/kerberos/lib is not added to /etc/ld.so.conf

How reproducible:
Always

Steps to Reproduce:
1. install a custom system with anaconda
2. see output from /tmp/install.log below
3.
	

Actual Results:Installing krb5-libs.
/var/tmp/rpm-tmp.15040: grep: command not found

Expected Results:  anaconda should have installed grep before krb5-libs

Additional info:

Chances are that in other systems grep does get installed before krb5-libs
due to some other requirement.
Comment 1 Mike A. Harris 2002-02-13 22:42:57 EST
pts/6 mharris@zod:~$ rpm -q --requires krb5-libs |grep grep
grep

RHL 7.1 has this fixed.

Note You need to log in before you can comment on or make changes to this bug.