Bug 501620 - f11 preview gnome live cd is unable to see computer storage
f11 preview gnome live cd is unable to see computer storage
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: gvfs (Show other bugs)
rawhide
i686 Linux
low Severity high
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-19 23:41 EDT by cornel panceac
Modified: 2015-03-03 17:40 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-20 15:33:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
devkit-disks dump (12.72 KB, text/plain)
2009-05-20 14:51 EDT, cornel panceac
no flags Details

  None (edit)
Description cornel panceac 2009-05-19 23:41:54 EDT
Description of problem:
booting my x40 thinkpad with f11 preview live cd , i don't see (hence i'm unable to mount) the hard disk partitions from nautilus. what i do see in nautilus is two 3.2 GB icons and the hard disk icon. clicking on them (aka trying to open) i get "Unable to mount location Can't mount file". Nothing shows up in /var/log/messages while i receive these errors. Also, the 3.2 GB icons is bogus, my fdisk -l is:

/dev/sda1 200megs linux partition and
/dev/sda2 38GB LVM

it is true that, i don't know why, fdisk -l also shows one /devdm-0 and one dm-1 3221 MB "things".

maybe it's important that my partitions inside lvm are encrypted and with previous versions of live cd i was unable to mount them (but at least i saw them)

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

considering that the live cd is released only once, i believe this bug will better be fixed :)
thank you
Comment 1 Tomáš Bžatek 2009-05-20 08:01:48 EDT
Would you please attach output of `devkit-disks --dump`?  (DeviceKit-disks package)
Comment 2 cornel panceac 2009-05-20 14:51:48 EDT
Created attachment 344865 [details]
devkit-disks dump 

here is the dump.
Comment 3 David Zeuthen 2009-05-20 15:08:16 EDT
Comment on attachment 344865 [details]
devkit-disks dump 

Please pay attention to setting the correct MIME type. Thanks.
Comment 4 cornel panceac 2009-05-20 15:13:37 EDT
i can see the attachment, can't you?
Comment 5 David Zeuthen 2009-05-20 15:26:36 EDT
(In reply to comment #4)
> i can see the attachment, can't you?  

The initial type was application/octet-stream so most browsers will download it and then you have to launch an external tool like less(1) to view it. If it's text/plain (as it is now) the attachment shows in the browser as a text file... which is more convenient... and will increase your changes of actually having people look at the bug ;-)
Comment 6 cornel panceac 2009-05-20 15:31:17 EDT
oh, now i understand :) thank you

btw, is the info useful?
Comment 7 David Zeuthen 2009-05-20 15:33:06 EDT
Yes, the information is useful thanks.

Anyway, the problem here is that we don't currently support LVM in the desktop shell / DeviceKit-disks. The reason you are getting the error message is that we don't know in advance that the encrypted volume contains something we don't support. E.g. we have to actually unlock the encrypted to discover what it contains (could as well have been ext3 or something else than LVM).

Closing as DEFERRED for now since we do have plans to support this in the upstream projects at some point... but just haven't gotten around to it just yet.
Comment 8 cornel panceac 2009-05-20 15:37:35 EDT
well, if only there were some docs somewhere describing how to use command line to workaround this issue ...

thank you very much.
Comment 9 cornel panceac 2009-05-27 02:24:24 EDT
i've just discovered that the same symptomps i have on a computer wich does not have lvm at all. this time it's a home made desktop with a 80 GB hard disk, and the live cd shows the hard disk, two 3,2 GB "things" and "filesystem" ( and i believe the "cd" was there too but i'm speaking out of memry now :) ).

Note You need to log in before you can comment on or make changes to this bug.