Bug 501621 - gvim does nothing from cmd line, empty frame when run from konqueror context menu
gvim does nothing from cmd line, empty frame when run from konqueror context ...
Status: CLOSED DUPLICATE of bug 501427
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-19 23:42 EDT by gene smith
Modified: 2009-05-26 03:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-26 03:48:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gene smith 2009-05-19 23:42:27 EDT
Description of problem:
When gvim is run from konsole cmd line, it does not produce a visible gui window. The gvim process runs (10618 below) but does nothing. All you can do is hit crtl-c and you see this:
$ gvim t.gds
^CICE default IO error handler doing an exit(), pid = 10618, errno = 4

When gvim is run from a right click in a context menu in konqueror, an empty VIM gui appear with just a frame and not menu and the file does not appear in the gui frame. To kill it you can click the close "x" several times and goes away.


Version-Release number of selected component (if applicable):
vim-X11-7.2.148-1.fc11.x86_64


How reproducible:
Always does this


Steps to Reproduce:
1. attempt to open a file with gvim on konsole cmd line
2. Nothing happens but gvim process seems to run
3. Ctrl-c kills it.
  
Actual results:
No gvim gui comes up. If run from konqueror context menu, VIM gui frame comes up but with no menu and opened file does not appear in the frame.


Expected results:
gvim gui should come up with a menu and the opened file visible.


Additional info:
gvim -u NONE -U NONE filename
makes no difference.

When run from kde alt-F2 nothing happens except gvim process runs (no gui). Don't know if it works in gnome (don't run it).

vim works as expected. vim -g says gui support not enabled when compiled.
Comment 1 gene smith 2009-05-21 23:03:31 EDT
FWIW, for my install, gvim works find in gnome. It only has the problem in kde.
Comment 2 gene smith 2009-05-25 15:41:41 EDT
Found a workaround for the problem. See bug 501427 which is essentially a duplicate of this.
Comment 3 Matěj Cepl 2009-05-26 03:48:38 EDT

*** This bug has been marked as a duplicate of bug 501427 ***
Comment 4 Matěj Cepl 2009-05-26 03:49:05 EDT
Per bug 501427 comment 10

Note You need to log in before you can comment on or make changes to this bug.