Bug 50164 - Bind bind-8.2.3-0.6.x problem
Bind bind-8.2.3-0.6.x problem
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-27 12:16 EDT by Need Real Name
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-01 15:06:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-07-27 12:16:52 EDT
bind-8.2.3-0.6.x (used as caching DNS) often gets 
to such state that it stops resolving SOME hostnames.

--------------------------------
dig www.clickxchange.com a

; <<>> DiG 8.3 <<>> www.clickxchange.com a 
;; res options: init recurs defnam dnsrch
;; res_nsend to server default -- 192.168.3.1: Connection timed out

Stange thing is that
dig clickxchange.com a
works OK. Only www.clickxchange.com can not be resolved.
Any other host names are OK
dig www.redhat.com a

; <<>> DiG 8.3 <<>> www.redhat.com a 
;; res options: init recurs defnam dnsrch
;; got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 4
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 3, ADDITIONAL: 3
;; QUERY SECTION:
;;	www.redhat.com, type = A, class = IN

;; ANSWER SECTION:
www.redhat.com.		1D IN A		216.148.218.197
www.redhat.com.		1D IN A		216.148.218.195

-------------------------------
The restart of bind fixes the problem:

dig www.clickxchange.com a

; <<>> DiG 8.3 <<>> www.clickxchange.com a 
;; res options: init recurs defnam dnsrch
;; got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 4
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 2, ADDITIONAL: 2
;; QUERY SECTION:
;;	www.clickxchange.com, type = A, class = IN

;; ANSWER SECTION:
www.clickxchange.com.	1D IN CNAME	clickxchange.com.
clickxchange.com.	1D IN A		216.115.239.51

---------------------------
There is no any bind-related error messages in /var/log/messages

I reported this problem a while ago, in bind 8.1.*
but as you can see from the logs above the problem still exists in Bind
8.2.3
Comment 1 Need Real Name 2001-07-27 12:21:32 EDT
This is a link to that old bug:

http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=10479
Comment 2 Bernhard Rosenkraenzer 2001-07-30 09:22:57 EDT
This looks like the uplink DNS (clickxchange.com) was down, the result "domain 
doesn't exist" got cached, and was looked up from the cache later - in that 
case, it should work again a day later.
Could this be the problem?
Comment 3 Need Real Name 2001-07-30 09:31:57 EDT
I do not think that this was the cause because
dig www.clickxchange.com a
took several seconds to reply.

If it were cached it would reply right away.
For all cached domains the DNS at 192.168.3.1
replies with no any delay.
Comment 4 Need Real Name 2001-07-30 09:34:44 EDT
Also, in the response from dig www.clickxchange.com a
there was a string having "Connection timed out"

;; res_nsend to server default -- 192.168.3.1: Connection timed out

which seems means that caching DNS at 192.168.3.1 did not send a response
in specific time period.

Note You need to log in before you can comment on or make changes to this bug.