Bug 501649 - Input Method should be enabled by default for en_US
Input Method should be enabled by default for en_US
Status: CLOSED DUPLICATE of bug 250226
Product: Fedora
Classification: Fedora
Component: imsettings (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-20 03:33 EDT by Parag Nemade
Modified: 2009-05-26 04:30 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-26 04:30:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Parag Nemade 2009-05-20 03:33:04 EDT
Description of problem:
iBus should be enabled by default for en-US. However, there has to be an option to enable it by default. iBus should be installed by default irrespective of package selection during Anaconda installation, since it's really important for non-english users, just like fonts.

Version-Release number of selected component (if applicable):
ibus-1.1.0.20090508-3.fc11.x86_64

How reproducible:
always

Steps to Reproduce:
1. install F11 in English locale
2. try to use iBus using ctrl+space
3.
  
Actual results:
no iBus installed with English locale

Expected results:
should install iBus with English locale.

Additional info:
https://fedoraproject.org/wiki/Test_Days:IBus#Test_Cases_and_Results
Comment 1 Peng Huang 2009-05-25 03:51:23 EDT
I think it is controlled by imchooser or imsetting.
Comment 2 Akira TAGOH 2009-05-25 04:30:27 EDT
What's the justification to enable IM by default for even English locale? I'm afraid the result of the test event still looks to me like a rare case though. and how about the footprint?

This is hard to decide to go in our team. you better get more agreements from community.
Comment 3 Parag Nemade 2009-05-25 04:37:24 EDT
As this is request from Ankit, I would like to hear from Ankit on comment #2.
Comment 4 Ankit Patel 2009-05-25 10:55:17 EDT
(In reply to comment #2)
> What's the justification to enable IM by default for even English locale? I'm
> afraid the result of the test event still looks to me like a rare case though.
> and how about the footprint?
> 
> This is hard to decide to go in our team. you better get more agreements from
> community.

Yeah, that's definitely better. I never intended to file a bug initially when I put my suggestion in the iBus test page.

Tagoh, what would be the best place to discuss this?

fedora-desktop-list?
fedora-devel-list?
fedora-i18n-list?
fedora-trans-list?


Thanks!
Ankit
Comment 5 Akira TAGOH 2009-05-26 00:55:57 EDT
devel would be better place but someone in other lists may be interested. so Cc'ing would be good IMHO.
Comment 6 Akira TAGOH 2009-05-26 04:30:32 EDT

*** This bug has been marked as a duplicate of bug 250226 ***

Note You need to log in before you can comment on or make changes to this bug.