Bug 501664 - Can not find root system
Can not find root system
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-20 04:53 EDT by Pierre-YvesChibon
Modified: 2009-05-26 04:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-25 05:18:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The report generated by preupgrade/anaconda when it crashes (58.81 KB, text/plain)
2009-05-20 04:53 EDT, Pierre-YvesChibon
no flags Details
Anaconda.log (3.99 KB, text/plain)
2009-05-25 05:00 EDT, Pierre-YvesChibon
no flags Details
storage.log (7.17 KB, text/plain)
2009-05-25 05:01 EDT, Pierre-YvesChibon
no flags Details

  None (edit)
Description Pierre-YvesChibon 2009-05-20 04:53:00 EDT
Created attachment 344760 [details]
The report generated by preupgrade/anaconda when it crashes

Description of problem:
I tried to upgrade my F-10 to F-11 using preupgrade.

run preupgrade as root

Version-Release number of selected component (if applicable):
preupgrade-1.0.1-1.fc10.noarch


How reproducible:
Always

Steps to Reproduce:
1.run preupgrade
2.reboot at the end
3.
  
Actual results:
Crash with an error message

Expected results:
Upgrade to F-11

Additional info:
See error message attached

In addition, I also tried to upgrade via a DVD, anaconda couldn't detect my hard drive and thus I could not go further than the partition screen
(ie: in https://fedoraproject.org/wiki/File:Tours_Fedora11_002_Install_Partition1.png the area "select the drive(s)..." was empty)

My smolt profile is :
http://www.smolts.org/client/show/pub_63e5b336-5505-4ffb-b32d-7815eac5fef2
Comment 1 Chris Lumens 2009-05-20 11:24:40 EDT
Do you actually have a dmraid setup?  If so, we're not at all detecting it and therefore you have no devices available for use.  Hence the crash.
Comment 2 Pierre-YvesChibon 2009-05-20 12:17:50 EDT
No I don't use anything special.

It's my computer from work, pretty new. I just install a normal Fedora without LVM or any other particularities (at least not that I am aware of :) ).
Comment 3 Pierre-YvesChibon 2009-05-25 04:00:30 EDT
[root@pingouLab ~]# dmraid -r
/dev/sda: isw, "isw_bdibhbjccd", GROUP, ok, 312581806 sectors, data@ 0

hm :s
Comment 4 Hans de Goede 2009-05-25 04:44:22 EDT
(In reply to comment #3)
> [root@pingouLab ~]# dmraid -r
> /dev/sda: isw, "isw_bdibhbjccd", GROUP, ok, 312581806 sectors, data@ 0
> 
> hm :s  

Ok, so you do have a dmraid set and we are not detecting it. Can you please start a regular dvd install again and then save /tmp/anaconda.log and /tmp/storage.log somewhere (use scp or a usb-stick) and attach them here?

You can switch to tty2 (CTRL + ALT + F2) to get a shell when you're at
the partitioning screen with no disks, and save the log files from that shell.

Thanks!
Comment 5 Pierre-YvesChibon 2009-05-25 05:00:37 EDT
Created attachment 345285 [details]
Anaconda.log
Comment 6 Pierre-YvesChibon 2009-05-25 05:01:03 EDT
Created attachment 345286 [details]
storage.log
Comment 7 Hans de Goede 2009-05-25 05:18:00 EDT
Ah, your disk used to be part of a dmraid array (so part of a raidset which can
be activated on some motherboards from the BIOS), but no longer is (you only have 1 disk), yet it still contains the isw raid (intel software raid) metadata on the disk, so we think its part of a set, does not find the other disks and then do not recognize it.

I guess you were lucky for this to work in F-10, this really is not a setup which
we want to support.

Your best way forward is to remove the isw metadata from the disk, so that
it gets seen as a normal disk. This can be done with the dmraid utility.

*WARNING* I've never done this, I know the BIOS will nuke the partition table
on the disk when you do this from the ISW BIOS (OROM), I do not expect dmraid to do the same, but be warned, this may cause data loss! *WARNING*

Ok, so you've made backups, right ? Then try the following command:
dmraid -x isw_bdibhbjccd

To remove the metadata.
Comment 8 Pierre-YvesChibon 2009-05-25 06:54:31 EDT
Thanks for your help.

The raid might be due to the installation procedure used by the ICT department.

My only concern (once backup are done and computer ready) is:
The system is dual boot with a windows (needed for some application at work), I expect they will not be touch.

Am I right ?
Comment 9 Hans de Goede 2009-05-25 07:16:56 EDT
(In reply to comment #8)
> Thanks for your help.
> 
> The raid might be due to the installation procedure used by the ICT department.
> 
> My only concern (once backup are done and computer ready) is:
> The system is dual boot with a windows (needed for some application at work), I
> expect they will not be touch.
> 
> Am I right ?  

You may want to check device manager in windows to see it is not seeing
the disk as part of a degraded (but still functional) raid set, if it is seeing
it like that I don't know how it will respond to the metadata going away. I suspect its just seeing it as a regular disk, in which case everything is fine.
Comment 10 Pierre-YvesChibon 2009-05-26 04:07:33 EDT
[root@pingouLab ~]# dmraid -r
/dev/sda: isw, "isw_bdibhbjccd", GROUP, ok, 312581806 sectors, data@ 0
[root@pingouLab ~]# dmraid -x isw_bdibhbjccd
ERROR: either the required RAID set not found or more options required
no raid sets and with names: "isw_bdibhbjccd"

:S
Comment 11 Hans de Goede 2009-05-26 04:27:27 EDT
(In reply to comment #10)
> [root@pingouLab ~]# dmraid -r
> /dev/sda: isw, "isw_bdibhbjccd", GROUP, ok, 312581806 sectors, data@ 0
> [root@pingouLab ~]# dmraid -x isw_bdibhbjccd
> ERROR: either the required RAID set not found or more options required
> no raid sets and with names: "isw_bdibhbjccd"
> 

Try doing just:
dmraid -x
Comment 12 Pierre-YvesChibon 2009-05-26 04:50:09 EDT
(In reply to comment #11)
> (In reply to comment #10)
> > [root@pingouLab ~]# dmraid -r
> > /dev/sda: isw, "isw_bdibhbjccd", GROUP, ok, 312581806 sectors, data@ 0
> > [root@pingouLab ~]# dmraid -x isw_bdibhbjccd
> > ERROR: either the required RAID set not found or more options required
> > no raid sets and with names: "isw_bdibhbjccd"
> > 
> 
> Try doing just:
> dmraid -x  

That one worked :)

But it seems that windows doesn't want to boot anymore... 

Thanks for your help

Note You need to log in before you can comment on or make changes to this bug.