Bug 501671 - kate crashes with SIGSEV during exit after command line start
kate crashes with SIGSEV during exit after command line start
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdesdk (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-20 05:14 EDT by Ian
Modified: 2009-09-07 22:34 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-07 22:34:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 185708 None None None Never

  None (edit)
Description Ian 2009-05-20 05:14:41 EDT
Description of problem:
kate crashes with a SIGSEV during exit from command line start

Version-Release number of selected component (if applicable):
kdesdk-4.2.2-2.fc10.i386

How reproducible:
always

Steps to Reproduce:
1. start "kate" from command line
2. select session if required, close tip of day
3. select File->Quit
  
Actual results:
KCrash: Application 'kate' crashing...
sock_file=/home/ian/.kde/socket-bose/kdeinit4__0


Expected results:
No crash

Additional info:
debug rpm does give some crash info:

Thread 1 (Thread 0x40032520 (LWP 30543)):
#0  0x40000416 in __kernel_vsyscall ()
#1  0x00673430 in __nanosleep_nocancel () from /lib/libc.so.6
#2  0x0067326e in sleep () from /lib/libc.so.6
#3  0x05c9170a in ?? () from /usr/lib/libkdeui.so.5
#4  0x05c9213c in KCrash::defaultCrashHandler () from /usr/lib/libkdeui.so.5
#5  <signal handler called>
#6  0x051e1e32 in QMenu::findIdForAction () from /usr/lib/libQtGui.so.4
#7  0x051e360d in ?? () from /usr/lib/libQtGui.so.4
#8  0x051e9ebb in ?? () from /usr/lib/libQtGui.so.4
#9  0x051ea992 in QMenu::mouseReleaseEvent () from /usr/lib/libQtGui.so.4
#10 0x05d04fd5 in KMenu::mouseReleaseEvent () from /usr/lib/libkdeui.so.5
#11 0x04dc6943 in QWidget::event () from /usr/lib/libQtGui.so.4
#12 0x051ecd79 in QMenu::event () from /usr/lib/libQtGui.so.4
#13 0x04d6fcec in QApplicationPrivate::notify_helper () from /usr/lib/libQtGui.so.4
#14 0x04d78941 in QApplication::notify () from /usr/lib/libQtGui.so.4
#15 0x05c2517d in KApplication::notify () from /usr/lib/libkdeui.so.5
#16 0x0276a75b in QCoreApplication::notifyInternal () from /usr/lib/libQtCore.so.4
#17 0x04d779ae in QApplicationPrivate::sendMouseEvent () from /usr/lib/libQtGui.so.4
#18 0x04de77e6 in ?? () from /usr/lib/libQtGui.so.4
#19 0x04de6887 in QApplication::x11ProcessEvent () from /usr/lib/libQtGui.so.4
#20 0x04e0ff6a in ?? () from /usr/lib/libQtGui.so.4
#21 0x007ff258 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#22 0x00802903 in ?? () from /lib/libglib-2.0.so.0
#23 0x00802ac1 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#24 0x02796188 in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4
#25 0x04e0f665 in ?? () from /usr/lib/libQtGui.so.4
#26 0x02768d8a in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#27 0x027691ca in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#28 0x0276b679 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#29 0x04d6fb67 in QApplication::exec () from /usr/lib/libQtGui.so.4
#30 0x00b4652d in kdemain (argc=1, argv=0xbfef9ce4) at /usr/src/debug/kdesdk-4.2.2/kate/app/katemain.cpp:250
#31 0x08048652 in main (argc=0, argv=0x0) at /usr/src/debug/kdesdk-4.2.2/i386-redhat-linux-gnu/kate/app/kate_dummy.cpp:3
Comment 1 Rex Dieter 2009-05-27 11:32:46 EDT
Is this reproducible with kde-4.2.3 (in updates)?
Comment 2 Ian 2009-05-27 11:56:58 EDT
% rpm -q kdelibs
kdelibs-4.2.3-2.fc10.i386

Still crashes as before.
Comment 3 Steven M. Parrish 2009-05-30 22:50:37 EDT
Thank you for the report.  This is an issue that needs to be addressed by the
upstream developers.  Please report this upstream at http://bugs.kde.org  and
add the upstream information to this report.
Comment 4 Ian 2009-06-01 11:19:37 EDT
OK, I think this is the bug:

https://bugs.kde.org/show_bug.cgi?id=190787

and this is fix:

http://websvn.kde.org/?view=rev&revision=961550

I assume this will be in KDE 4.2.4, scheduled for this week :)

Sorry, I should have found this on KDE first.
Comment 5 Rex Dieter 2009-06-01 11:30:49 EDT
np, looks like qt-4.5.1 mitigates this issue as well.

We'll pick up the fix when 4.2.4, sure (working on it).
Comment 6 Kevin Kofler 2009-06-01 11:38:46 EDT
Unfortunately that commit only went into 4.3 trunk, not the 4.2 branch.

(Grrr, yet another bugfix which didn't get backported. The KDE project needs to have a stronger policy about bugfixes having to be backported.)
Comment 7 Steven M. Parrish 2009-06-28 20:43:40 EDT
Do we want to backport this ourselves or just wait for 4.3?

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Rex Dieter 2009-06-28 20:50:22 EDT
At this point, I'm inclined to wait for 4.3

Note You need to log in before you can comment on or make changes to this bug.