Bug 501750 - Can not install/start kvm domain with libvirt-python and virt-manager
Can not install/start kvm domain with libvirt-python and virt-manager
Status: CLOSED CANTFIX
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-20 11:24 EDT by simon.krenz
Modified: 2010-03-16 13:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-28 04:19:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description simon.krenz 2009-05-20 11:24:35 EDT
OS: CentOS 5.3
libvirt version: libvirt-0.3.3-14.el5_3.1
libvirt-phython version: libvirt-python-0.3.3-14.el5_3.1
python-virtinst version: python-virtinst-0.300.2-12.el5

Description of problem:

I can not install a new virtual machine with virt-install for a qemu-kvm domain, if I use the flag --accelerate to activate kvm support. Output looks like this:

Starting install...
virDomainCreateLinux() failed 
Domain installation may not have been
 successful.  If it was, you can restart your domain
 by running 'virsh start test'; otherwise, please
 restart your installation.
Wed, 20 May 2009 11:15:51 ERROR    virDomainCreateLinux() failed 
Traceback (most recent call last):
  File "/usr/sbin/virt-install", line 560, in ?
    main()
  File "/usr/sbin/virt-install", line 492, in main
    dom = guest.start_install(conscb, progresscb, wait=(not wait))
  File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 822, in start_install
    return self._do_install(consolecb, meter, wait)
  File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 843, in _do_install
    self.domain = self.conn.createLinux(install_xml, 0)
  File "/usr/lib64/python2.4/site-packages/libvirt.py", line 573, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: virDomainCreateLinux() failed 

The command with which I got this is following:

virt-install --connect qemu:///system -n test -r 512 --vcpus=1 -f /data/images/sles10sp2-gui.img -s 12 -c /dev/cdrom --vnc --noautoconsole --os-type linux --os-variant sles10 --network=bridge:eth0 --accelerate

After many tries I decided to create the domain xml manually. This one is what I created:

<domain type='kvm'>
  <name>sles10sp2-gui</name>
  <uuid>de543bfe-9556-beca-3765-7eef8edfcbc8</uuid>
  <memory>524288</memory>
  <currentMemory>524288</currentMemory>
  <vcpu>1</vcpu>
  <os>
    <type>hvm</type>
    <boot dev='hd'/>
  </os>
  <features>
    <acpi/>
  </features>
  <clock offset='utc'/>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>restart</on_reboot>
  <on_crash>destroy</on_crash>
  <devices>
    <emulator>/usr/bin/qemu-kvm</emulator>
    <disk type='file' device='disk'>
      <source file='/data/images/sles10sp2-gui.img'/>
      <target dev='hda'/>
    </disk>
    <interface type='bridge'>
      <mac address='00:16:3e:33:38:be'/>
      <source bridge='eth0'/>
    </interface>
    <input type='mouse' bus='ps2'/>
    <graphics type='vnc' port='-1' listen='127.0.0.1'/>
  </devices>
</domain>

If I want to start this domain, after a virsh -c qemu:///system define sles10sp2-gui I got this after a virsh start:

error: Failed to start domain sles10sp2-gui

And with the virt-manager per remote this:

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 498, in run_domain
    vm.startup()
  File "/usr/share/virt-manager/virtManager/domain.py", line 508, in startup
    self.vm.create()
  File "/usr/lib/python2.6/dist-packages/libvirt.py", line 287, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: Unknown failure

Greetings Simon
Comment 1 simon.krenz 2009-05-20 15:32:05 EDT
Additional: there is nothing inside the logs under /var/log/libvirt/qemu.
Comment 2 Daniel Veillard 2009-05-28 04:19:17 EDT
libvirt-0.3.3 has no support for KVM, not a bug, lack of feature.
You will have to wait until libvirt is rebased in Centos.

Daniel

Note You need to log in before you can comment on or make changes to this bug.