This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 501757 - Loader no longer shows the mac address during "Networking Device" selection
Loader no longer shows the mac address during "Networking Device" selection
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 517123 (view as bug list)
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2009-05-20 11:44 EDT by James Laska
Modified: 2013-09-02 02:36 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-29 10:17:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Laska 2009-05-20 11:44:32 EDT
Description of problem:

Loader no longer shows the mac address during "Networking Device" selection.  It worked with yesterdays rawhide but is missing with today.  I do not know which component to attribute this change to yet. 

Booting into rawhide-20090520 to perform a network install..

                   ┌─────────┤ Networking Device ├──────────┐
                   │                                        │
                   │ You have multiple network devices on   │
                   │ this system. Which would you like to   │
                   │ install through?                       │
                   │                                        │
                   │                eth0 -                  │
                   │                eth1 -                  │
                   │                eth2 -                  │
                   │                                        │
                   │  ┌────┐     ┌──────────┐    ┌──────┐   │
                   │  │ OK │     │ Identify │    │ Back │   │
                   │  └────┘     └──────────┘    └──────┘   │
                   │                                        │
                   │                                        │
                   └────────────────────────────────────────┘


Booting into rawhide-20090519 to perform a network install..

            +----------------+ Networking Device +----------------+
            |                                                     |
            | You have multiple network devices on this system.   |
            | Which would you like to install through?            |
            |                                                     |
            |  eth0 - Ethernet device eth0 - 00:11:25:7e:28:64    |
            |  eth1 - Ethernet device eth1 - 00:0d:60:b9:6b:c8    |
            |  eth2 - Ethernet device eth2 - 00:11:25:7e:28:65    |
            |                                                     |
            |    +----+         +----------+         +------+     |
            |    | OK |         | Identify |         | Back |     |
            |    +----+         +----------+         +------+     |
            |                                                     |
            |                                                     |
            +-----------------------------------------------------+

I've experienced this on x86_64 and ppc so far
Comment 1 Bill Nottingham 2009-05-20 12:40:07 EDT
I can reproduce this at will in rawhide.

I replace loader on the initrd with a locally built one (no code changes) and it works.
Comment 2 Jesse Keating 2009-05-20 12:56:12 EDT
Uh oh, that smacks of environmental differences.  Was your local built loader done in a minimal chroot, or just on your regular install file system?  I'm wondering if we need some tool brought along that we aren't getting in the chroot?
Comment 3 Bill Nottingham 2009-05-20 13:52:45 EDT
Switching to RPM_OPT_FLAGS for CFLAGS makes it reproducible. Patch posted, although it's really not obvious to me why this would fail now.
Comment 5 Jason Woofenden 2009-05-27 13:29:58 EDT
Bill Nottingham,

There's an off-by-one error at your link:

http://git.fedorahosted.org/git/?p=anaconda.git;a=commitdiff;h=e8a00c3a91072e9d00b877f70266735375b9bdbf

Filling the buffer with 64 nulls, then reading in (up to) 64 bytes, could overwrite all the nulls. This code needs to either:

1) use the return value of read() instead of strlen()

2) make the buffer (and memset()) one byte bigger (65 bytes)

or

3) try reading only 63 bytes.


Take care,   - Jason
Comment 6 Bill Nottingham 2009-05-27 13:39:57 EDT
In practice, the sysfs files are never that long. But defensive programming, etc., yes.
Comment 7 James Laska 2009-05-29 10:17:59 EDT
No longer observing this failure as of anaconda-11.5.0.56.  This will be fixed in F11.  Thanks!
Comment 8 John W. Linville 2009-09-29 11:22:49 EDT
*** Bug 517123 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.