Bug 501801 - RHEL4.8x86 GA hts5.3-15 fails Profiler/Storage test with 10G nic VC Flex10 environment
RHEL4.8x86 GA hts5.3-15 fails Profiler/Storage test with 10G nic VC Flex10 en...
Status: CLOSED WORKSFORME
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
5.3
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Greg Nichols
Lawrence Lim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-20 14:56 EDT by Garry Wong
Modified: 2014-03-25 20:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-03 12:25:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test logs (3.09 MB, application/x-zip-compressed)
2009-07-16 15:25 EDT, Garry Wong
no flags Details

  None (edit)
Description Garry Wong 2009-05-20 14:56:59 EDT
Description of problem: RHEL4.8x86 GA hts5.3-15 fails Profiler and Storage test with 10G nic VC Flex10 environment. But the test passed with 1G nic environment. This is a Blade AMD platform server


Version-Release number of selected component (if applicable):
hts5.3-15
RHEL4.8x86 GA release

How reproducible:

Yes.

Steps to Reproduce:
1. Install RHEL4.8x86 GA onto SUT with 10G nic VC Flex 10 environment
2. Open modprobe.conf
3. Add "options oprofile timer=1" to the end of the file and reboot
4. Installl hts5.3-15
5. Run hts plan
6. hts run --test profiler and hts run --test storage
7. Tests failed.

  
Actual results: Failed


Expected results:Should pass as 1G nic environment


Additional info:See attached log
Comment 1 Garry Wong 2009-05-20 15:32:16 EDT
So far we only see this issue on AMD platform. Not sure on Intel platform.

Thanks.
Comment 2 Rob Landry 2009-07-16 13:12:07 EDT
Garry, do you have the logs which show this failure?  Also it might be work a look into if hts-5.3-17 solves the issue, though I suspect the profiler change in -17 is unrelated.
Comment 3 Garry Wong 2009-07-16 15:25:38 EDT
Created attachment 354043 [details]
Test logs

Hi Rob,

See attached logs. We will verify with -17 and update you.

Thanks for your time.

Regards,

Garry
Comment 4 Rob Landry 2009-11-09 17:25:50 EST
Hi Garry,

I'm not certain if this is still an issue but the storage failures are caused by the partition setup:

Error: cciss/c0d0 is currently in use by LVM.
It cannot be tested. You may need to reinstall.
...finished running ./storage.py, exit code=1

...and the oproile failures are caused by this...

Failed to open profile device: Cannot allocate memory
Using 2.6+ OProfile kernel interface.
Couldn't start oprofiled.

...which IIRCis caused by the irq timer resource being taken by the nmi_watchdog, this can be worked around by disabling the nmi_watchdog or setting the oprofile option to use the software timer via "options oprofile timer=1" in modprobe.conf.

The LVM issue still exists but the timer mode should be worked around in the test suite itself now.

-Rob

Note You need to log in before you can comment on or make changes to this bug.