Bug 501814 - Anaconda installer does not recognize Intel SSD drive
Anaconda installer does not recognize Intel SSD drive
Status: CLOSED DUPLICATE of bug 499733
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-20 16:20 EDT by Bryan Christ
Modified: 2009-08-10 05:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-10 05:26:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda log (12.34 KB, text/plain)
2009-05-20 17:02 EDT, Bryan Christ
no flags Details
storage log (17.83 KB, text/plain)
2009-05-20 17:02 EDT, Bryan Christ
no flags Details

  None (edit)
Description Bryan Christ 2009-05-20 16:20:01 EDT
Description of problem:

Boot to Fedora 11 preview with an Intel SSD drive as the primary disk.  Even thought the driver is enumerated as /dev/sda and can be manually partitioned, Anaconda does not see this as an available device for installation.

This was not a problem on F10.

Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chris Lumens 2009-05-20 16:41:39 EDT
Please attach /tmp/storage.log and /tmp/anaconda.log to this bug report.  Thanks.
Comment 2 Bryan Christ 2009-05-20 17:02:29 EDT
Created attachment 344876 [details]
anaconda log
Comment 3 Bryan Christ 2009-05-20 17:02:46 EDT
Created attachment 344877 [details]
storage log
Comment 4 Chris Lumens 2009-05-21 10:19:25 EDT
What do you mean by "does not see this as an available device for installation"?  Can you describe the error message or failure case you're getting?
Comment 5 Bryan Christ 2009-05-21 10:43:47 EDT
During the "partition wizard, device sda is nowhere to be found.  I can see my two other physical devices (SATA harddrives sdb and sdc) and I can also see md0 (which is comprised of sdb1 and sdc1).  The physical device sda is not present anywhere in the GUI.  If I switch over to a tty, I can access the drive with fdisk and other tools without problem.  If there is a way to send a screenshot I will be glad to do that.
Comment 6 Bryan Christ 2009-05-27 14:55:45 EDT
Chris,

Any update?
Comment 7 Chris Lumens 2009-05-28 15:39:27 EDT
My guess is that because your sda device is detected as a dmraid member (according to storage.log - grep for "sda") and we are therefore throwing it out.  Do you know if this device used to be a part of a dmraid setup?  If so, you may need to wipe the metadata from it, or make sure dmraid is disabled in your BIOS.  Hans would probably know better.
Comment 8 Bryan Christ 2009-05-28 15:45:11 EDT
The drive should not have any metadata on it since I dd over the first several GB of the drive.  Also, my BIOS is set to AHCI and not fake-raid.
Comment 9 Bug Zapper 2009-06-09 12:12:16 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Hans de Goede 2009-08-10 05:26:31 EDT
Hi,

There has been a behavioural change between F-10 and F-11 where in F-10 drives
which contain invalid / stale dmraid (BIOS RAID) metadata / which were part of an incomplete BIOS RAID set would be just seen as the raw disks, where as F-11 these
drives are ignored.

In F-10 in cases where dmraid was detected unwantedly (in case of a complete set, but being disabled in the BIOS for example), the BIOS RAID detection could be avoided with nodmraid. In F-11 this option currently does not work, this is bug
499733. Once 499733 is fixed you can workaround your issue using the nodmraid
installer cmdline option.

Note that a better solution would be to remove the unwanted BIOS RAID metadata from the disks, this can be done using "dmraid -x", be sure to make backups before doing this! "dmraid -x" should leave your data intact, but better safe then sorry.

Also only do this if you really want your disks to not be part of a BIOS RAID set, if for example windows is currently using the disks as a BIOS RAID set you do not want to do this!

*** This bug has been marked as a duplicate of bug 499733 ***

Note You need to log in before you can comment on or make changes to this bug.