Bug 501815 - Searching for bugs in existing command-line utililities
Searching for bugs in existing command-line utililities
Status: CLOSED NOTABUG
Product: Bugzilla
Classification: Community
Component: Query/Bug List (Show other bugs)
3.6
All Linux
low Severity low (vote)
: ---
: ---
Assigned To: Simon Green
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-20 16:24 EDT by Penelope Fudd
Modified: 2014-10-12 18:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-19 20:04:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Penelope Fudd 2009-05-20 16:24:14 EDT
Description of problem:
I want to report a bug in 'wc', the word-count program, which is part of the coreutils rpm.  Searching for 'coreutils' or 'wc' gives me thousands of unrelated bugs.

Version-Release number of selected component (if applicable):
bugzilla.redhat.com version 3.2

How reproducible:
Always

Steps to Reproduce:
1. Search for 'wc'
2. Search for 'coreutils'
3. Sob
  
Actual results:
A list of bug reports relating to the 'wc' command.

Expected results:
Typing in '/usr/bin/wc' should list just bug reports in that program.

Additional info:
I'd *really* like it if I could find bugs related to any particular file on the system.  

Or if I could submit a list of rpms and get a list of bugs for those exact versions of the rpms, with links to either the latest rpm, or if the latest rpm has the bug, then an older, less-buggy rpm.

The original bug: wc doesn't count the last line in a file if there is no newline at the end.  It's possible to have a 0-line file containing megabytes of data.  Is this some kind of POSIX-compliant bug?  Actually, after looking at the POSIX standard for 'wc' (http://www.opengroup.org/onlinepubs/000095399/utilities/wc.html) it turns out it is.  Sigh.
Comment 1 Noura El hawary 2009-05-21 06:42:23 EDT
Hi Penelope,

This is the wrong place to file this bug, please file it under the right product that the bug is existing in.

Noura
Comment 2 Penelope Fudd 2009-05-21 14:36:23 EDT
The bug is in Bugzilla.

The program I mentioned (wc) is merely an example.  The chances of finding an existing bug report on any unix command (especially a two-letter command) is next to zero.  Go try it, if you don't believe me.

For another example, try the 'monit' command.  Because 'monit' is a substring of 'monitor', and people do a lot of monitoring in their bug reports, it's impossible to find bug reports on monit the way Bugzilla searches for things.

If you could search for a given rpm, the problem would go away.  Existing bug reports don't have rpm information, but new ones could.
Comment 3 David Lawrence 2010-01-15 11:55:10 EST
Red Hat Bugzilla is now using version 3.4 of the Bugzilla codebase and
therefore this bug will need to be re-verified against the new release. With
the updated code this bug may no longer be relevant or may have been fixed in
the new code. Updating bug version to 3.4.
Comment 4 Penelope Fudd 2010-01-15 12:54:06 EST
Searched for 'wc'... found lots of unrelated programs: problem re-verified 
Searched for 'coreutils'... found policycoreutils: problem re-verified
Comment 5 David Lawrence 2010-08-25 17:42:55 EDT
Red Hat has now upgraded to Bugzilla 3.6 and this bug will now be reassigned to that version. It would be helpful to the Bugzilla Development Team if this bug is verified to still be an issue with the latest version. If it is no longer an issue, then feel free to close, otherwise please comment that it is still a problem and we will try to address the issue as soon as we can.

Thanks
Bugzilla Development Team
Comment 6 Penelope Fudd 2010-08-25 17:49:23 EDT
Searched for 'wc' using quick and advanced search, found lots of unrelated programs: problem re-verified
Comment 7 Penelope Fudd 2010-08-25 17:56:18 EDT
Selecting 'find all words' in advanced search cut down on the nonspecific hits, but if wc isn't in the subject, is advanced search going to find it?

I'd still like to search by rpm package name or name+version.
Comment 8 David Lawrence 2010-08-25 18:09:19 EDT
(In reply to comment #6)
> Searched for 'wc' using quick and advanced search, found lots of unrelated
> programs: problem re-verified

Can you detail exactly how you are searching for bugs related to 'wc' and 'coreutils'? If you type these words in the quick search field in the top of the Bugzilla pages, it will find more than you are wanting to see since it will also find bugs with 'wc' in the summary and other places.

For a more specific search, I would use the query.cgi (Advanced) form to select the coreutils component from the component select list and then search as it will narrow the search significantly.

Dave
Comment 9 David Lawrence 2010-08-25 18:10:06 EDT
query.cgi basically AND's all of the fields together, so if you select 'coreutils' in the component list and then use 'wc' in the summary field, it will find bugs that only match both of those criteria.

Dave
Comment 10 Penelope Fudd 2010-08-25 18:50:43 EDT
Yes, that does cut down the search considerably, thanks.

I guess the problem was that the user has to determine which rpm a program comes from, using rpm -qf, and then select that rpm from the component list.  If that step could be incorporated into bugzilla, it would be nice.

Is there a way to search for bugs in a particular version of an rpm?

Thanks.
Comment 11 David Lawrence 2010-08-26 14:50:52 EDT
(In reply to comment #10)
> Is there a way to search for bugs in a particular version of an rpm?

Not currently. Bugzilla doesn't store any component specific versioning. There is a "Fixed In" field which some people use to place the rpm version that has a fix but not all use and it doesn't enforce any strict format. You can do a comment search that contains a version of an rpm if someone has mentioned in there bug details maybe but not guaranteed.

Dave
Comment 12 Penelope Fudd 2010-08-26 16:40:52 EDT
Since it's the individual rpm packages that contain bugs, it would be nice if bugzilla made that link explicit, instead of having the tenuous or absent linkage that exists now.  Call this a wishlist item, I guess.. :-)
Comment 13 Simon Green 2012-06-19 20:04:24 EDT
Not all products in Bugzilla have a link between component and RPM. The Bugzilla product is a good example of this. Even in the Red Hat Enterprise Linux products, not all components are RPMs, and not all RPMs are components.

Although the Red Hat Bugzilla team are not responsible for the components that in the Red Hat products, I assume that they are happy with the list of components for the product.

  -- simon
Comment 14 Penelope Fudd 2012-06-19 20:24:36 EDT
Are you saying that, because 10% of bugzilla's use cases do not come in rpm files, that this feature would not be extremely useful?

Note You need to log in before you can comment on or make changes to this bug.