Bug 501818 - JkWatchdogInterval makes non-threaded apache hang
JkWatchdogInterval makes non-threaded apache hang
Status: CLOSED WONTFIX
Product: Red Hat Application Server
Classification: Retired
Component: mod_jk (Show other bugs)
2.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Ted Ross
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-20 16:50 EDT by Chris Duryee
Modified: 2015-10-12 14:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-12 14:12:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Duryee 2009-05-20 16:50:30 EDT
Description of problem:

In one of our environments, we have an apache with prefork MPM that serves mod_jk requests as well as CGI.

When we upgraded to mod_jk 1.2.28, we turned on JkWatchdogInterval. This caused mod_jk to eventually hang all of the worker processes.

After consulting with Sam Mendenhall, it turns out that JkWatchdogInterval is incompatible with prefork.

Can you add a check to ignore the JkWatchdogInterval flag (and perhaps print a warning) if it's set on a prefork apache? 

Version-Release number of selected component (if applicable): 1.2.28
Comment 3 Chris Duryee 2015-10-12 14:12:55 EDT
Bug is very old, closing out.

Note You need to log in before you can comment on or make changes to this bug.