Bug 501820 - expect: Tcl_SetObjLength called with shared object
expect: Tcl_SetObjLength called with shared object
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: expect (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
: 554750 (view as bug list)
Depends On:
Blocks: 583491
  Show dependency treegraph
 
Reported: 2009-05-20 16:59 EDT by Josh P.
Modified: 2010-04-18 16:02 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 583491 (view as bug list)
Environment:
Last Closed: 2010-03-10 04:44:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh P. 2009-05-20 16:59:18 EDT
Description of problem:

'send "hello"' gives an error: 'Tcl_SetObjLength called with shared object'

Version-Release number of selected component (if applicable):

expect-5.43.0-17.fc11.i586

How reproducible:

always

Steps to Reproduce:

[user@system ~]$ expect 
expect1.1> send "hello"
helloTcl_SetObjLength called with shared object
Aborted
[user@system ~]$ 

Additional info:

renaming /usr/share/tcl8.5/history.tcl seems to solve the problem.  Not sure why.

See:
http://forums13.itrc.hp.com/service/forums/questionanswer.do?admit=109447627+1242851118864+28353475&threadId=1310861
Comment 1 Bug Zapper 2009-06-09 12:12:27 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Tim Taiwanese Liim 2010-03-05 10:59:19 EST
I also encountered this core dump just now in F12.

Version:
    expect-5.43.0-19.fc12.x86_64

How reproducible:
    Always


Procedure to reproduce:
    1. create a expect script, containing these:
        #!/usr/bin/expect
        set values {1 3 5 7 2 4 6 8}
    2. run the expect script.
    3. from bash command line, run
        [timliim@yam ~]$  /usr/bin/expect 
        expect1.1> set values {1 3 5 7 2 4 6 8}
        Tcl_SetObjLength called with shared object
        Aborted (core dumped)

Actual results:
    - step 2 ran fine, no core dump
    - step 3, expect core dump

Expected results:
    expect should not core dump in step 3.

Additional info:
  - backtrace
        Program received signal SIGABRT, Aborted.
        0x0000003ef46326c5 in raise () from /lib64/libc.so.6
        (gdb) bt
        #0 raise () from /lib64/libc.so.6
        #1 abort () from /lib64/libc.so.6
        #2 Tcl_PanicVA () from /usr/lib64/libtcl8.5.so
        #3 Tcl_Panic () from /usr/lib64/libtcl8.5.so
        #4 Tcl_SetObjLength () from /usr/lib64/libtcl8.5.so
        #5 exp_interpreter () from /usr/lib64/libexpect5.43.so
        #6 main ()
Comment 3 Tim Taiwanese Liim 2010-03-05 11:01:34 EST
These two bugs are related:
#1 bug501820 expect: Tcl_SetObjLength called with shared object
#2 bug554750 [abrt] crash in expect-5.43.0-19.fc12

#2 seems to be dup of #1.
Comment 4 Vitezslav Crhonek 2010-03-10 04:37:16 EST
*** Bug 554750 has been marked as a duplicate of this bug. ***
Comment 5 Vitezslav Crhonek 2010-03-10 04:44:28 EST
Expect updated to latest upstream CVS snapshot, which fixes this issue.
Comment 6 Tim Taiwanese Liim 2010-03-10 10:42:15 EST
Vitezslav,
Thanks for fast action!
Comment 7 Yigal 2010-03-26 12:47:08 EDT
Hi,

You were identifying the OS as FEDORA, but it seems like I'm hitting this bug on SOLARIS as well:


expect1.1> send "hell"
hellTcl_SetObjLength called with shared object
Abort


TCL : tclsh8.5
EXPECT: expect version 5.43.0

uname -a
SunOS <snip node name> 5.10 Generic_125100-10 sun4v sparc SUNW,Sun-Fire-T200

Can you confirm it is not an OS dependent? and how can I get the fix?

Thanks,
-Yigal
Comment 8 Tim Taiwanese Liim 2010-03-26 18:24:13 EDT
Yigal,
From what I can see this bug is OS independent, and is likely to occur
on Solaris as well.  We need to wait Vitezslav for the authoritative
answer though.  Judging from Comment #5, the fix is to upgrade the the
latest stable expect (http://expect.nist.gov/).
Comment 9 Vitezslav Crhonek 2010-03-29 07:14:47 EDT
Hi Yigal,
The best solution will be to upgrade expect (http://sourceforge.net/projects/expect/).
Comment 10 Yigal 2010-03-29 08:30:16 EDT
Thank you folks

-Yigal

Note You need to log in before you can comment on or make changes to this bug.