Bug 501827 - Spamassassin default user "nobody" raises problem with bayes, autolearn, etc
Spamassassin default user "nobody" raises problem with bayes, autolearn, etc
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: spamassassin (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-20 17:59 EDT by Javier Alejandro Castro
Modified: 2009-05-21 12:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-21 12:08:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Javier Alejandro Castro 2009-05-20 17:59:17 EDT
Description of problem:

 There is no "untouched package way" to use spamassassin with autolearn auto-whitelist feature just fine.

Version-Release number of selected component (if applicable):

 spamassassin-3.2.5-5.fc11.x86_64

How reproducible:

 always

Steps to Reproduce:
1. Install spamassassin
2. Enable spamd service with default config
3. Look at syslog for spamd process. Lots of errors trying to access/create /.spamassassin/ directory, etc
  
Actual results:

 Errors. Spamassassin not being able to autolearn spam messages.

Expected results:

 Out of the box option for enabling spamd for in-site configuration, and being able to build the bayes database and auto-whitelist thing

Additional info:

 It seems spamd runs as user nobody, and user nobody home is ... /? so spamd tries to use/create /.spamassassin/user_prefs, etc...

 May be the best is to create a spamd user on the RPM scripts, etc and run spamc/spamd with that user? may be home must be set to /var/lib/spamassassin ?
Comment 1 Warren Togami 2009-05-21 12:08:56 EDT
I can't reproduce this issue.  spamd reads and writes .spamassassin in the home directory of the user running spamc.

As you said, probably an issue with cyrus-imapd.  Talk to that project.

Note You need to log in before you can comment on or make changes to this bug.