Bug 501835 - wesnoth shouldn't depend on fonts at a particular path
wesnoth shouldn't depend on fonts at a particular path
Status: CLOSED DUPLICATE of bug 478634
Product: Fedora
Classification: Fedora
Component: wesnoth (Show other bugs)
rawhide
i386 Linux
low Severity high
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-20 18:26 EDT by Christian Tosta
Modified: 2009-05-21 08:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-21 08:11:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to spec file (362 bytes, patch)
2009-05-20 18:27 EDT, Christian Tosta
no flags Details | Diff

  None (edit)
Description Christian Tosta 2009-05-20 18:26:08 EDT
Description of problem:
Wesnoth not showing text.


Version-Release number of selected component (if applicable): wesnoth-1.4.7-1


How reproducible: ever


Steps to Reproduce:
1. Open wesnoth
2. Verify the text boxes without text

  
Actual results:
Text is not show


Expected results:
Text must appear


Additional info:
Text no appearing because are broken links in wesnoth fonts dir:

[tosta@horyzon ~]$ ls -l /usr/share/wesnoth/fonts/
total 0
lrwxrwxrwx 1 root root 38 Mai 20 18:49 DejaVuSans.ttf ->
/usr/share/fonts/dejavu/DejaVuSans.ttf
lrwxrwxrwx 1 root root 58 Mai 20 18:49 sazanami-gothic.ttf ->
/usr/share/fonts/sazanami-fonts-gothic/sazanami-gothic.ttf
lrwxrwxrwx 1 root root 42 Mai 20 18:49 wqy-zenhei-gb2312.ttf ->
/usr/share/fonts/wqy-zenhei/wqy-zenhei.ttc

[tosta@horyzon ~]$ ls -l /usr/share/fonts/dejavu/DejaVuSans.ttf
ls: impossível acessar /usr/share/fonts/dejavu/DejaVuSans.ttf: Arquivo
ou diretório não encontrado

[tosta@horyzon ~]$ ls -l /usr/share/fonts/sazanami-fonts-gothic/sazanami-gothic.ttf
ls: impossível acessar /usr/share/fonts/sazanami-fonts-gothic/sazanami-gothic.ttf: Arquivo
ou diretório não encontrado

[tosta@horyzon ~]$ ls -l /usr/share/fonts/wqy-zenhei/wqy-zenhei.ttc
ls: impossível acessar /usr/share/fonts/wqy-zenhei/wqy-zenhei.ttc: Arquivo
ou diretório não encontrado

Package wesnoth-data must require these packages:
dejavu-fonts
sazanami-fonts-gothic
wqy-zenhei-fonts
Comment 1 Christian Tosta 2009-05-20 18:27:08 EDT
Created attachment 344896 [details]
Patch to spec file

Patch to spec attached
Comment 2 Warren Togami 2009-05-20 19:49:43 EDT
Let's not require fonts in the package.  Instead we should patch the package to use the fonts in the system location.  If the fonts are not installed then too bad for the user.
Comment 3 Christian Tosta 2009-05-20 21:42:19 EDT
Hum... But if the user choose to user other fonts as your system default? He can uses dejavu-lgc-fonts or other in place of dejavu-fonts. Specific fonts like sazanami-fonts-gothic and wqy-zenhei-fonts shouldn't required by default. Users can not need it. Too, so much fonts installed can make Xorg to run poorly.
Comment 4 Warren Togami 2009-05-20 21:51:24 EDT
I tested this.  In my experience the only font that is different from system standard for those languages that is missing some glyphs is the Chinese one.  The real bug here is it insists upon using fonts at a certain location in the filesystem.  It should just ask the OS and live with whatever it is given like all other apps.
Comment 5 Gwyn Ciesla 2009-05-21 08:11:00 EDT
I agree, hence my BZ in an upstream bug I filed.

*** This bug has been marked as a duplicate of bug 478634 ***

Note You need to log in before you can comment on or make changes to this bug.