Bug 501841 - ipa group-remove-member returns 0 upon error
ipa group-remove-member returns 0 upon error
Status: CLOSED ERRATA
Product: freeIPA
Classification: Community
Component: ipa-admintools (Show other bugs)
unspecified
All Linux
low Severity medium
: v2 release
: ---
Assigned To: Rob Crittenden
Chandrasekar Kannan
:
Depends On:
Blocks: 431020
  Show dependency treegraph
 
Reported: 2009-05-20 19:57 EDT by Michael Gregg
Modified: 2015-01-04 18:38 EST (History)
2 users (show)

See Also:
Fixed In Version: freeipa-2.0.0-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-28 05:32:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Gregg 2009-05-20 19:57:15 EDT
Description of problem:
trying to remove a member from a group that doesn't exist in that group returns 0. 

Version-Release number of selected component (if applicable):
ipa-server-2.0-2.20090513.el5ipa

How reproducible:
always

Steps to Reproduce:
1. kinit as admin
2. ipa group-add examplegroup
3. ipa group-add exampleremove
4. ipa group-add-member --groups=exampleremove examplegroup
5. ipa group-remove-member --groups=exampleremove examplegroup
6. ipa group-remove-member --groups=exampleremove examplegroup
  
Actual results:
[root@iparhel5-vma ~]# ipa group-remove-member --groups=exampleremove examplegroup
These entries failed to be removed from the group:
'cn=exampleremove,cn=groups,cn=accounts,dc=dsdev,dc=sjc,dc=redhat,dc=com'
[root@iparhel5-vma ~]# echo $?
0

Expected results:
[root@iparhel5-vma ~]# ipa group-remove-member --groups=exampleremove examplegroup
[root@iparhel5-vma ~]# ipa group-remove-member --groups=exampleremove examplegroup
[root@iparhel5-vma ~]# echo $?
<something not 0>

Additional info:
This seems to be related to various other bugs, I'm creating this as a placeholder.
Comment 2 Rob Crittenden 2010-10-08 10:17:50 EDT
https://fedorahosted.org/freeipa/ticket/274

Note You need to log in before you can comment on or make changes to this bug.