Bug 501868 - /usr/share/gallery2/lib/smtp/smtp.php breaks ecard
/usr/share/gallery2/lib/smtp/smtp.php breaks ecard
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gallery2 (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-21 03:42 EDT by Joel
Modified: 2009-06-15 22:44 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.3-12.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-15 22:44:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Modified smtp.php (5.79 KB, application/octet-stream)
2009-05-21 03:42 EDT, Joel
no flags Details

  None (edit)
Description Joel 2009-05-21 03:42:24 EDT
Created attachment 344918 [details]
Modified smtp.php

Description of problem:

When sending an html ecard with the ecard module, the Content-Type header tag is actually included in the body.  

This is because the smtp.php code is editing the headers (and messing them up)!

Attached code fixes the problem.

How reproducible:

Use ecard plugin to send an html email.  See that is isn't parsed correctly in thunderbird or gmail.
Comment 1 Fedora Update System 2009-05-21 12:05:46 EDT
gallery2-2.3-11.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gallery2-2.3-11.fc10
Comment 2 Fedora Update System 2009-05-25 17:08:25 EDT
gallery2-2.3-11.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gallery2'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-5433
Comment 3 Fedora Update System 2009-05-27 12:36:42 EDT
gallery2-2.3-12.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gallery2-2.3-12.fc10
Comment 4 Fedora Update System 2009-05-28 03:59:24 EDT
gallery2-2.3-12.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gallery2'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-5545
Comment 5 Bug Zapper 2009-06-09 12:13:06 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Fedora Update System 2009-06-15 22:43:53 EDT
gallery2-2.3-12.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.