Bug 501887 - Error downloading RPMs in netinstall CD when upgrading.
Error downloading RPMs in netinstall CD when upgrading.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-21 04:42 EDT by Krzysztof Adamski
Modified: 2009-06-10 09:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-10 09:32:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krzysztof Adamski 2009-05-21 04:42:14 EDT
Description of problem:
I've upgraded Fedora 10 to Fedora 11-Preview using netinstall CD. While doing that I had a problem with downloading some RPM files, however. I've checked the logs (pressing ctrl+alt+F3, I think) and I found out that installer did try few mirrors, each 10 times but it was getting following error from FTP/HTTP servers all the time:
[Errono 4] Requested Range Not Satisiable due to unobtainable file length.

After some tries it gave me an information it couldn't download RPM and i had two choises:
- stop installation and reboot leaving my system in inconsistent state
- try again (which failed all the time)

I didn't want inconsistent system so I've investigated the problem a little more and I found out that it's easy to fix - I had to manually (using console in ctrl+alt+F2) remove RPM files that failed to download from /mnt/sysimage/var/cache/yum/rawhide/packages/ and then press "retry". 

I know that I shouldn't have this RPM files in /mnt/sysimage/var/cache/yum/rawhide/packages/ but somehow they where there and installer wasn't smart enough to handle this situation (but it could be).

Version-Release number of selected component (if applicable):
Fedora 11-Preview netinstall CD

How reproducible:
I didn't try as I fixed this issue myself. 

Additional info:
I'm not sure how to actually reproduce this but I think you should have bad RPM file in the cache while upgrading. From the error message given by FTP/HTTP servers I believe in my situation the file was to big.
Comment 1 Bug Zapper 2009-06-09 12:13:30 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Chris Lumens 2009-06-10 09:32:53 EDT
This will be fixed in the next build of anaconda.  Thanks for the bug report.

Note You need to log in before you can comment on or make changes to this bug.