Bug 501893 - String parameters should be checked for != NULL
String parameters should be checked for != NULL
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On: 501894
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-21 04:51 EDT by Richard W.M. Jones
Modified: 2011-07-14 15:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-14 15:10:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2009-05-21 04:51:14 EDT
We should check that NULL is not being passed
for String parameters.  At the moment if a program
does this, it probably causes a segfault.  The calling
program is technically incorrect, but we should check
for this case anyway, particularly since in some bindings
(eg. Perl) an undefined string parameter might be
passed as NULL.
Comment 1 Mark McLoughlin 2009-05-25 10:49:53 EDT
Moving upstream, since it's only a safety check for incorrect programs
Comment 2 Richard W.M. Jones 2010-05-19 07:34:48 EDT
Patch posted upstream:
https://www.redhat.com/archives/libguestfs/2010-May/msg00117.html

Note You need to log in before you can comment on or make changes to this bug.