Bug 501918 - RFE - RHN Satellite probes assigned to registered clients
RFE - RHN Satellite probes assigned to registered clients
Status: CLOSED DEFERRED
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Monitoring (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Milan Zazrivec
Red Hat Satellite QA List
:
Depends On:
Blocks: 462714
  Show dependency treegraph
 
Reported: 2009-05-21 06:15 EDT by Tomas Lestach
Modified: 2015-05-29 16:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-05-29 16:11:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Lestach 2009-05-21 06:15:19 EDT
Description of problem:
Every single created "RHN Satellite" probe is assigned to a registered client. But RHN Satellite probes get executed locally on the satellite itself, not on the registered clients. Actually they have nothing in common with registered clients.

Version-Release number of selected component (if applicable):
sat5.3, but I suppose, the problem lasts since RHN Satellite probes were introduced

How reproducible:
always

Steps to Reproduce:
1. register a client to the satellite, enable monitoring
2. create any RHN Satellite probe (f.e. RHN Satellite: Process Counts), push scout
3. check the result of the probe
4. check number of processes manually on the satellite and on the client
5. compare 3)^ and 4)^
6. check the probe details and make sure, it's assigned to the registered client

Actual results:
The "RHN Satellite: Process Counts" probe returns number of processes on the satellite itself. All the RHN Satellite probes are executed on the satellite and not on the registered clients. And that is correct! But why are all the "RHN Satellite" probes assigned to any of the registered clients?

Expected results:
"RHN Satellite" probes are assigned to the local satellite itself.

Additional info:
Note, that if you have no client registered to the satellite at all, you're unable to create any RHN Satellite probe.
Comment 1 Clifford Perry 2009-05-21 09:59:08 EDT
Hi Tomas, you are correct, your observations. This has always been like this for 'Satellite probes'. I do not want to address this within 530 cycles and moving this to triage for possible future inclusion in either 5.4 or 6.0 Sat. 

Cliff

Note You need to log in before you can comment on or make changes to this bug.