Bug 501923 - libvirt with latest qemu-kvm error: "Cannot determine QEMU argv syntax /usr/bin/qemu-kvm"
libvirt with latest qemu-kvm error: "Cannot determine QEMU argv syntax /usr/b...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Mark McLoughlin
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12VirtBlocker
  Show dependency treegraph
 
Reported: 2009-05-21 06:40 EDT by Mark McLoughlin
Modified: 2009-06-05 09:23 EDT (History)
7 users (show)

See Also:
Fixed In Version: 0.6.2-11.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-21 06:58:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2009-05-21 06:40:31 EDT
libvirt-0.6.3-8.fc12.x86_64
qemu-system-x86-0.10.50-4.kvm86.fc12.x86_64

Trying to start a guest gives:

  $> virsh start rawhide
  error: Failed to start domain rawhide
  error: internal error Cannot determine QEMU argv syntax /usr/bin/qemu-kvm

Should be fixed by:

  http://git.et.redhat.com/?p=libvirt.git;a=commitdiff;h=2b3fcdc378
Comment 1 Mark McLoughlin 2009-05-21 06:58:04 EDT
Fixed in F12 now

* Thu May 21 2009 Mark McLoughlin <markmc@redhat.com> - 0.6.3-9.fc12
- Fix qemu argv detection with latest qemu (bug #501923)
Comment 2 Fedora Update System 2009-05-21 09:25:08 EDT
libvirt-0.6.2-9.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libvirt-0.6.2-9.fc11
Comment 3 Fedora Update System 2009-05-22 05:53:18 EDT
libvirt-0.6.2-10.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libvirt-0.6.2-10.fc11
Comment 4 sean 2009-06-01 22:04:49 EDT
I'm seeing the same with libvirt-0.6.4-1:

virsh start xp-asterisk
error: Failed to start domain xp-asterisk
error: internal error Cannot determine QEMU argv syntax /usr/bin/qemu-kvm
Comment 5 Daniel Veillard 2009-06-03 03:39:52 EDT
w.r.t. comment #4 can you make 100% sure you restarted the libvirt
daemon after the libvirt rpm update ?

Daniel
Comment 6 Mark McLoughlin 2009-06-03 09:10:34 EDT
Works for me with libvirt-0.6.4-1
Comment 7 Fedora Update System 2009-06-04 17:21:08 EDT
libvirt-0.6.2-11.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2009-06-05 09:23:57 EDT
libvirt-0.6.2-12.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libvirt-0.6.2-12.fc11

Note You need to log in before you can comment on or make changes to this bug.