Bug 501931 - Apache won't start missing directory.
Summary: Apache won't start missing directory.
Keywords:
Status: CLOSED DUPLICATE of bug 501123
Alias: None
Product: Fedora
Classification: Fedora
Component: httpd
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Joe Orton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-05-21 11:56 UTC by Andreas Pedersen
Modified: 2009-05-21 12:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-05-21 12:01:04 UTC
Type: ---


Attachments (Terms of Use)

Description Andreas Pedersen 2009-05-21 11:56:06 UTC
Apache won't start up missing directory.

$ service httpd start

Logfile
 -  /var/log/httpd/error_log
[notice] SELinux policy enabled; httpd running as context unconfined_u:system_r:httpd_t:s0
[notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[notice] Digest: generating secret for digest authentication ...
[notice] Digest: done
[emerg] (2)No such file or directory: mod_fcgid: Can't create share memory for size %zu byte



$ rpm -q mod_fcgid
mod_fcgid-2.2-10.fc11.x86_64
$ rpm -ql  mod_fcgid
/etc/httpd/conf.d/fcgid.conf
/usr/lib64/httpd/modules/mod_fcgid.so
/usr/share/doc/mod_fcgid-2.2
/usr/share/doc/mod_fcgid-2.2/AUTHOR
/usr/share/doc/mod_fcgid-2.2/COPYING
/usr/share/doc/mod_fcgid-2.2/ChangeLog
/usr/share/doc/mod_fcgid-2.2/README.RPM
/usr/share/doc/mod_fcgid-2.2/configuration.htm
/usr/share/doc/mod_fcgid-2.2/directives.htm
/var/run/mod_fcgid

Here we see on the last line that the mod_fcgid is created on the wrong place or is the configuration file wrong ?

$ tail -2 /etc/httpd/conf.d/fcgid.conf 
SocketPath run/mod_fcgid
SharememPath run/mod_fcgid/fcgid_shm


How to solve this issue is to create an new directory.
$ mkdir /var/run/httpd/mod_fcgid

Comment 1 Joe Orton 2009-05-21 12:01:04 UTC

*** This bug has been marked as a duplicate of bug 501123 ***


Note You need to log in before you can comment on or make changes to this bug.