Bug 502002 - Unable to connect to GSM/HSDPA network via Option GTM378, if username and password are empty
Unable to connect to GSM/HSDPA network via Option GTM378, if username and pas...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-21 10:17 EDT by Leonid Kanter
Modified: 2009-07-24 15:44 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.7.1-8.git20090708.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-24 15:44:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
HSOconnect connection log (1.77 KB, text/plain)
2009-05-21 10:53 EDT, Leonid Kanter
no flags Details

  None (edit)
Description Leonid Kanter 2009-05-21 10:17:57 EDT
Description of problem:

With built-in module Option GTM378 I'm unable to connect to my HSDPA network if username and password fields are empty.

Version-Release number of selected component (if applicable):

NetworkManager-0.7.1-4.git20090414.fc11.x86_64

How reproducible:

Always

Steps to Reproduce:
1. On equipment with Option GTM378, create new mobile broadband connection with empty username and password.
2. Try to establish connection
  
Actual results:

Connection will not be established

Expected results:

Connection should be established

Additional info:

If I set username and password to 1 and 1, it's possible to establish connection.

Debug log with empty username and password:

NetworkManager: <debug> [1242924370.858999] nm_serial_debug(): Sending: 'AT$QCPDPP=1,1,"",""
'
NetworkManager: <info>  Activation (ttyHS0) Stage 2 of 5 (Device Configure) complete.
NetworkManager: <debug> [1242924370.983541] nm_serial_debug(): Got: '

ERROR

'NetworkManager: <WARN>  hso_auth_done(): Authentication failed
NetworkManager: <info>  (ttyHS0): device state change: 5 -> 9
NetworkManager: <debug> [1242924370.983754] nm_serial_device_close(): Closing device 'ttyHS0'
NetworkManager: <info>  Marking connection 'Utel' invalid.
NetworkManager: <info>  Activation (ttyHS0) failed.


Debug log with non-empty username and password:

NetworkManager: <info>  (ttyHS0): device state change: 6 -> 5
NetworkManager: <debug> [1242924536.763527] nm_serial_debug(): Sending: 'AT$QCPDPP=1,1,"1","1"
'
NetworkManager: <info>  Activation (ttyHS0) Stage 2 of 5 (Device Configure) complete.
NetworkManager: <debug> [1242924536.871548] nm_serial_debug(): Got: '

OK

'
NetworkManager: <info>  Authentication successful!


It should be fixed, because it's not obvious for user that he/she must enter some username and password, if it's not required by network operator. And it's possible to connect without username and password using other tools, like HSOconnect.

Equipment info:

[root@localhost ~]# cu -l ttyHS1
Connected.
ate1
OK
ati3
Manufacturer: Option N.V.
Model: GTM378
Revision: 2.5.6Hd (Date: Dec 21 2007, Time: 13:54:03)

OK
Comment 1 Leonid Kanter 2009-05-21 10:49:09 EDT
According to hsoconnect log, this error is non-fatal and could be ignored. Here is part of the log:  

Clicked Connect'AT+CGDCONT=1,"IP","3g.utel.ua"'
'OK
''AT$QCPDPP=1,1,"",""'
'ERROR
''AT_OPDPP=1,1,"",""'
'ERROR
''AT_OWANCALL=1,1,1'
'OK
''AT_OWANDATA=1'
'ERROR
''AT_OWANDATA=1'
'_OWANDATA: 1, 94.179.232.163, 0.0.0.0, 82.207.66.250, 82.207.66.241, 0.0.0.0, 0.0.0.0, 72000

Complete HSOconnect log will be attached.
Comment 2 Leonid Kanter 2009-05-21 10:53:07 EDT
Created attachment 344977 [details]
HSOconnect connection log
Comment 3 Dan Williams 2009-06-03 14:21:58 EDT
Should be fixed by 936ad6a6665af0a68a53845d0b6aac1c7f0a3f0e upstream.
Comment 4 Bug Zapper 2009-06-09 12:15:43 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Fedora Update System 2009-06-19 09:44:26 EDT
wpa_supplicant-0.6.8-4.fc11, NetworkManager-0.7.1-5.git20090617.fc11, mobile-broadband-provider-info-0.20090602-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wpa_supplicant NetworkManager mobile-broadband-provider-info'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6769
Comment 6 Leonid Kanter 2009-06-20 16:26:08 EDT
I can confirm now that problem is fixed. Here is connection log:

NetworkManager: <info>  (ttyHS0): device state change: 4 -> 5 (reason 0)
NetworkManager: <debug> [1245529326.870826] nm_serial_debug(): Sending: 'AT$QCPDPP=1,1,"",""
'
NetworkManager: <info>  Activation (ttyHS0) Stage 2 of 5 (Device Configure) complete.
NetworkManager: <debug> [1245529326.994194] nm_serial_debug(): Got: '

ERROR

'
NetworkManager: <info>  Attempting alternate authentication (AT_OPDPP)...
NetworkManager: <debug> [1245529326.994458] nm_serial_debug(): Sending: 'AT_OPDPP=1,1,"",""
'
NetworkManager: <debug> [1245529327.122196] nm_serial_debug(): Got: '

ERROR

'
NetworkManager: <debug> [1245529327.122358] nm_serial_debug(): Sending: 'AT_OWANCALL=1,0,1
'
NetworkManager: <debug> [1245529327.250199] nm_serial_debug(): Got: '

OK

'
NetworkManager: <debug> [1245529333.000658] nm_serial_debug(): Sending: 'AT_OWANCALL=1,1,1
'
NetworkManager: <debug> [1245529333.138205] nm_serial_debug(): Got: '

OK

'
NetworkManager: <debug> [1245529334.418178] nm_serial_debug(): Got: '

OK

_OWANCALL: 1, 1

'
NetworkManager: <info>  Connected, Woo!



Thank you very much for the fix.
Comment 7 Fedora Update System 2009-06-26 22:41:30 EDT
wpa_supplicant-0.6.8-4.fc11, NetworkManager-0.7.1-5.git20090617.fc11, mobile-broadband-provider-info-0.20090602-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wpa_supplicant NetworkManager mobile-broadband-provider-info'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6769
Comment 8 Fedora Update System 2009-07-02 01:43:43 EDT
wpa_supplicant-0.6.8-4.fc11, mobile-broadband-provider-info-0.20090602-2.fc11, NetworkManager-0.7.1-6.git20090617.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wpa_supplicant mobile-broadband-provider-info NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6769
Comment 9 Fedora Update System 2009-07-16 03:07:03 EDT
NetworkManager-0.7.1-8.git20090708.fc11, mobile-broadband-provider-info-1.20090707-1.fc11, wpa_supplicant-0.6.8-4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager mobile-broadband-provider-info wpa_supplicant'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6769
Comment 10 Fedora Update System 2009-07-24 15:44:19 EDT
NetworkManager-0.7.1-8.git20090708.fc11, mobile-broadband-provider-info-1.20090707-1.fc11, wpa_supplicant-0.6.8-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.