Bug 502073 - livecd-tools: keep /etc/sysconfig/mkinitrd on the disc
livecd-tools: keep /etc/sysconfig/mkinitrd on the disc
Status: CLOSED DUPLICATE of bug 446935
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-21 14:20 EDT by Matt Domsch
Modified: 2009-05-21 14:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-21 14:37:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2009-05-21 14:20:13 EDT
Description of problem:
If someone takes a LiveCD and makes a LiveUSB key, and then later does a 'yum upgrade' or otherwise installs a new kernel into that environment, the initramfs created by mkinitrd does not contain the drivers needed to boot that environment again.

Now, livecd-tools did generate a usable initramfs, and had created the /etc/sysconfig/mkinitrd file.  But it also _deleted_ it after being done with it.

I recommend we not delete that file, but leave it in the image.


Version-Release number of selected component (if applicable):
livecd-tools 024
git head 8ddeb5380c41e9a65218bbd4e92cec8210255acf
Comment 1 Jeremy Katz 2009-05-21 14:37:53 EDT
Leaving it on the image instead, though, breaks installs from the live image as you'd then end up with a live initrd instead of the system one.

Bug 446935 is the overall "we should somehow make it so you can update the kernel on your live image" bug, so going to mark this a dupe of it

*** This bug has been marked as a duplicate of bug 446935 ***

Note You need to log in before you can comment on or make changes to this bug.