This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 502099 - Trying to remove "admin" from systemgroup admin list returns success even though admin is not removed
Trying to remove "admin" from systemgroup admin list returns success even tho...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API (Show other bugs)
530
All Linux
low Severity low
: ---
: ---
Assigned To: Brad Buckingham
Sayli Karmarkar
:
Depends On:
Blocks: 456996
  Show dependency treegraph
 
Reported: 2009-05-21 16:52 EDT by Sayli Karmarkar
Modified: 2009-09-10 15:55 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:55:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sayli Karmarkar 2009-05-21 16:52:17 EDT
Description of problem:

Create a system group foobar

>>> server.systemgroup.addOrRemoveAdmins(key, "foobar", ["admin"], 0)
1

Expected results:
Error message saying:
"Satellite admin cannot be removed from systemgroup administrator list"
Comment 1 Brad Buckingham 2009-05-27 11:36:43 EDT
This issue will actually apply to both Satellite and Organization administrators; therefore, the updates will address both.  Also, since this capability isn't something that can be added/removed to those users, the exception will be generated for both add & remove.

Since the api (addOrRemoveAdmins) applies to multiple users, if any of those users is a Sat/Org admin, the exception will be generated and no users will be updated.  

Also, the exception will generate an error like:

Changing administrator access is not allowed for Satellite and Organization Administrators.  These users are granted access by default; therefore, the following users should be removed from the input: user1, user2.
Comment 2 Brad Buckingham 2009-05-27 14:00:33 EDT
master git commit: a04981236fd4315535c85b8b68ce786d04806933
vader git commit: 5e3ebb7927f16f4f745eb68ddbb9d3224f62865c
Comment 3 Sayli Karmarkar 2009-06-02 20:42:16 EDT
verified.

>>> server.systemgroup.addOrRemoveAdmins(key, "foobar", ["foobar","admin"], 1)
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
  File "/usr/lib/python2.4/xmlrpclib.py", line 1096, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib/python2.4/xmlrpclib.py", line 1383, in __request
    verbose=self.__verbose
  File "/usr/lib/python2.4/xmlrpclib.py", line 1147, in request
    return self._parse_response(h.getfile(), sock)
  File "/usr/lib/python2.4/xmlrpclib.py", line 1286, in _parse_response
    return u.close()
  File "/usr/lib/python2.4/xmlrpclib.py", line 744, in close
    raise Fault(**self._stack[0])
xmlrpclib.Fault: <Fault 2202: 'redstone.xmlrpc.XmlRpcFault: Changing administrator access is not allowed for Satellite and Organization administrators.  These users are granted access by default; therefore, the following users should be removed from the input: admin'>
Comment 4 Milan Zazrivec 2009-08-21 07:39:36 EDT
Verified in stage -> RELEASE_PENDING
Comment 5 Brandon Perkins 2009-09-10 15:55:54 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.