Bug 502108 - Anaconda unhandled exception during Hard Drive install from liveCD
Anaconda unhandled exception during Hard Drive install from liveCD
Status: CLOSED DUPLICATE of bug 501768
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:6581e01543be08b71...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-21 18:26 EDT by Andreas Tiemeyer
Modified: 2009-11-15 02:58 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-22 09:20:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (94.10 KB, text/plain)
2009-05-21 18:26 EDT, Andreas Tiemeyer
no flags Details
Attached traceback automatically from anaconda. (65.00 KB, text/plain)
2009-06-10 05:47 EDT, sergio
no flags Details
Attached traceback automatically from anaconda. (27.90 KB, text/plain)
2009-06-13 08:34 EDT, Erik Gieseler
no flags Details
Attached traceback automatically from anaconda. (101.02 KB, text/plain)
2009-06-13 16:30 EDT, David Ramirez
no flags Details
Attached traceback automatically from anaconda. (144.29 KB, text/plain)
2009-06-13 16:35 EDT, David Ramirez
no flags Details
Attached traceback automatically from anaconda. (28.42 KB, text/plain)
2009-06-14 13:05 EDT, Brennon Loveless
no flags Details
Attached traceback automatically from anaconda. (37.08 KB, text/plain)
2009-07-23 09:49 EDT, RavanH
no flags Details
Attached traceback automatically from anaconda. (32.80 KB, text/plain)
2009-08-01 20:06 EDT, sayhar
no flags Details
Attached traceback automatically from anaconda. (51.82 KB, text/plain)
2009-10-04 06:46 EDT, Gabriele Pohl
no flags Details
Attached traceback automatically from anaconda. (51.64 KB, text/plain)
2009-10-04 08:41 EDT, Gabriele Pohl
no flags Details
Attached traceback automatically from anaconda. (15.95 KB, text/plain)
2009-11-15 02:58 EST, Marek Zdražil
no flags Details

  None (edit)
Description Andreas Tiemeyer 2009-05-21 18:26:32 EDT
The following was filed automatically by anaconda:
anaconda None exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/parted/disk.py", line 142, in duplicate
    return Disk(PedDisk=self.__disk.duplicate())
  File "/usr/lib/anaconda/storage/devices.py", line 717, in __init__
    self._origPartedDisk = self.partedDisk.duplicate()
  File "/usr/lib/anaconda/storage/devicetree.py", line 1087, in addUdevDiskDevice
    initcb=cb, initlabel=initlabel, **kwargs)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1160, in addUdevDevice
    device = self.addUdevDiskDevice(info)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1627, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 288, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 72, in storageInitialize
    storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1330, in nextClicked
    self.anaconda.dispatch.gotoNext()
PartedException: Assertion (!disk->update_mode) at disk.c:421 in function ped_disk_destroy() failed.
Comment 1 Andreas Tiemeyer 2009-05-21 18:26:42 EDT
Created attachment 345032 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2009-05-22 09:20:21 EDT

*** This bug has been marked as a duplicate of bug 501768 ***
Comment 3 sergio 2009-06-10 05:47:47 EDT
Created attachment 347175 [details]
Attached traceback automatically from anaconda.
Comment 4 Erik Gieseler 2009-06-13 08:34:59 EDT
Created attachment 347738 [details]
Attached traceback automatically from anaconda.
Comment 5 David Ramirez 2009-06-13 16:30:36 EDT
Created attachment 347767 [details]
Attached traceback automatically from anaconda.
Comment 6 David Ramirez 2009-06-13 16:35:02 EDT
Created attachment 347768 [details]
Attached traceback automatically from anaconda.
Comment 7 Brennon Loveless 2009-06-14 13:05:14 EDT
Created attachment 347834 [details]
Attached traceback automatically from anaconda.
Comment 8 RavanH 2009-07-23 09:49:08 EDT
Created attachment 354862 [details]
Attached traceback automatically from anaconda.
Comment 9 sayhar 2009-08-01 20:06:32 EDT
Created attachment 355905 [details]
Attached traceback automatically from anaconda.
Comment 10 Gabriele Pohl 2009-10-04 06:46:28 EDT
Created attachment 363588 [details]
Attached traceback automatically from anaconda.
Comment 11 Gabriele Pohl 2009-10-04 08:41:36 EDT
Created attachment 363595 [details]
Attached traceback automatically from anaconda.
Comment 12 Marek Zdražil 2009-11-15 02:58:05 EST
Created attachment 369568 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.