Bug 502110 - virt-manager does not re-connect after libvirtd restart
virt-manager does not re-connect after libvirtd restart
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
11
x86_64 All
medium Severity high
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11VirtTarget
  Show dependency treegraph
 
Reported: 2009-05-21 18:30 EDT by IBM Bug Proxy
Modified: 2009-09-07 03:41 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 20:03:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot showing error (846.63 KB, image/png)
2009-05-21 18:31 EDT, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 53465 None None None Never

  None (edit)
Description IBM Bug Proxy 2009-05-21 18:30:50 EDT
=Comment: #0=================================================
PAVAN NAREGUNDI <pavan.naregundi@in.ibm.com> - 

Screenshot showing error

While shutting down the fc11 guest, got a error as below

"Error shutting down domain: cannot send data: Broken pipe"

==============================
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 507, in shutdown_domain
    vm.shutdown()
  File "/usr/share/virt-manager/virtManager/domain.py", line 565, in shutdown
    self.vm.shutdown()
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 472, in shutdown
    if ret == -1: raise libvirtError ('virDomainShutdown() failed', dom=self)
libvirtError: cannot send data: Broken pipe
==============================

Steps to repoduce:
1. Start the fc11 guest(not sure but, any guest may work)
2. restart the libvirtd demon 

# /etc/init.d/libvirtd restart
Stopping libvirtd daemon:                                  [  OK  ]
Starting libvirtd daemon:                                  [  OK  ]
#

3. Trying to shutdown the guets through virt-manager shoud give the above mentioned error

There are no special logs in /var/log/libvirt/qemu/fc11.log  

virsh # version 
Compiled against library: libvir 0.6.2
Using library: libvir 0.6.2
Using API: QEMU 0.6.2
Running hypervisor: QEMU 0.10.1


Attaching the screen shot of error
=================================================
Hello Red Hat,

mirroring this KVM/libvirt issue for your awareness...

fwiw, this error doesn't happen if we don't restart the libvirtd service while running the guest.

Thanks for your support.
Comment 1 IBM Bug Proxy 2009-05-21 18:31:03 EDT
Created attachment 345036 [details]
Screenshot showing error
Comment 2 Mark McLoughlin 2009-05-25 11:44:43 EDT
Please use "rpm -q virt-manager python-virtinst libvirt qemu-system-x86" to let us know exactly what versions you are using

I can't reproduce this here, could you try again with the latest libvirt and qemu from updates-testing ?

  https://admin.fedoraproject.org/updates/libvirt-0.6.2-11.fc11
  https://admin.fedoraproject.org/updates/F11/FEDORA-2009-5050
Comment 3 IBM Bug Proxy 2009-05-26 03:30:54 EDT
------- Comment From pavan.naregundi@in.ibm.com 2009-05-26 03:23 EDT-------
(In reply to comment #8)
> Please use "rpm -q virt-manager python-virtinst libvirt qemu-system-x86" to let
> us know exactly what versions you are using
>

virt-manager-0.7.0-4.fc11.x86_64
python-virtinst-0.400.3-8.fc11.noarch
libvirt-0.6.2-8.fc11.x86_64
qemu-system-x86-0.10-16.fc11.x86_64

> I can't reproduce this here, could you try again with the latest libvirt and
> qemu from updates-testing ?
>
> https://admin.fedoraproject.org/updates/libvirt-0.6.2-11.fc11
> https://admin.fedoraproject.org/updates/F11/FEDORA-2009-5050
>

Updated qemu and libvirt.

virt-manager-0.7.0-4.fc11.x86_64
python-virtinst-0.400.3-8.fc11.noarch
libvirt-0.6.2-11.fc11.x86_64
qemu-system-x86-0.10.4-4.fc11.x86_64

Tried with windows guest.. Still seeing the error. Restarting the libvirtd demon after the guest boots UP is important to reproduce this issue.

Thanks
Pavan
Comment 4 Mark McLoughlin 2009-05-26 04:29:25 EDT
It seems to be that if you restart libvirtd while running virt-manager, virt-manager doesn't re-open the connection. As soon as you restart, this traceback gets spewed over and over to virt-manager.log:

[Tue, 26 May 2009 10:18:47 virt-manager 4413] ERROR (engine:160) Could not refresh connection qemu:///system
<class 'libvirt.libvirtError'> cannot send data: Broken pipe
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 154, in _tick
    self.connections[uri]["connection"].tick()
  File "/usr/share/virt-manager/virtManager/connection.py", line 994, in tick
    self.hostinfo = self.vmm.getInfo()
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 1295, in getInfo
    if ret is None: raise libvirtError ('virNodeGetInfo() failed', conn=self)
libvirtError: cannot send data: Broken pipe
Comment 5 Cole Robinson 2009-05-26 10:11:53 EDT
Upstream virt-manager won't spew the above error anymore:

http://hg.et.redhat.com/cgi-bin/hg-virt.cgi/applications/virt-manager--devel/rev/32d53a01e595

But we don't attempt a reconnect.
Comment 6 Bug Zapper 2009-06-09 12:18:10 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Cole Robinson 2009-07-14 20:03:19 EDT
I think this is a WONTFIX actually. From the virt-manager perspective, we can't tell if libvirtd has been restarted or not. So we could try something like a quick reconnect incase someone did a 'service libvirtd restart', but with possibly password prompts and supressing error messages, it would seriously be more trouble than its worth.

It's very little extra effort for the user to 'Right Click -> Connect' in manager window (with current upstream).
Comment 8 IBM Bug Proxy 2009-07-15 18:50:49 EDT
------- Comment From emachado@linux.vnet.ibm.com 2009-07-15 18:45 EDT-------
Hello Red Hat,

as you mentioned in a previous comment, upstream virt-manager was changed in order to avoid the error message when restarting libvirtd daemon. Would you know when this fix will be available for Fedora? Is this already on rawhide? Please provide the virt-manager package version if possible.

Thanks for your support.
Comment 9 Mark McLoughlin 2009-08-07 09:53:30 EDT
(In reply to comment #8)
>  Hello Red Hat,

Hello IBM :-)
>
> as you mentioned in a previous comment, upstream virt-manager was changed in
> order to avoid the error message when restarting libvirtd daemon. Would you
> know when this fix will be available for Fedora? Is this already on rawhide?
> Please provide the virt-manager package version if possible.

That is fixed by virt-manager-0.8.0-1.fc12 in rawhide
Comment 10 IBM Bug Proxy 2009-09-07 03:41:15 EDT
------- Comment From santwana.samantray@in.ibm.com 2009-09-07 03:34 EDT-------
Hello Redhat,

I verified this issue in Fedora12 - Alpha release(k.v- 2.6.31-0.125.4.2.rc5.git2.fc12.x86_64), and its working fine. I am able to shutdown the guest through virt-manager , even after restarting libvirtd.
The version of virt-manager is "virt-manager-0.8.0-2.fc12.noarch"

Thanks,
Santwana

Note You need to log in before you can comment on or make changes to this bug.